lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Asfand Qazi <...@sanger.ac.uk>
Subject Re: Cannot get highlighting to work
Date Fri, 01 Jun 2012 09:08:34 GMT
On 31/05/12 21:10, Jack Krupansky wrote:
> Try a query that uses a term that doesn't split an alphanumeric term
> into two terms.
>
> Then check to see what field type you used for the symbol and
> marker_symbol fields and whether the analyzer for that field type has
> changed in 3.6.
>

Aha - yes, not using number fields makes the highlighter work.  The 
analyzer had been changed by another dev (helpfully) for the fields I 
was trying to highlight to solr.KeywordTokenizerFactory - I changed it 
back to solr.WhitespaceTokenizerFactory, as it was in the 1.4 config.

With a lot of hope I tried to fire the same query, but the exact same 
thing happened - the highlighting for a document is an empty document 
(i.e. { } ) just like before.

Any other clues?

Thanks



>
>
>
> -- Jack Krupansky
> -----Original Message----- From: Asfand Qazi
> Sent: Thursday, May 31, 2012 12:32 PM
> To: solr-user@lucene.apache.org
> Subject: Cannot get highlighting to work
>
> Hello,
>
> I am having problems doing highlighting a Solr 3.6 instance, while it
> was working just fine before on our 1.4 instance.
>
> The solrconfig.xml and schema.xml files are located here:
>
> https://github.com/mpi2/mpi2_solr/blob/master/multicore/main/conf/schema.xml
>
>
> (please note the incorrect line wrapping - it should be on one line)
>
>
> https://github.com/mpi2/mpi2_solr/blob/master/multicore/main/conf/solrconfig.xml
>
>
> (please note the incorrect line wrapping - it should be on one line)
>
>
> The query I fire off (which worked on the 1.4 instance) is:
>
> /solr/main/select?q=Cbx1&wt=json&hl=true&hl.fl=*&hl.usePhraseHighlighter=true
>
>
> (please note the incorrect line wrapping - it should be on one line)
>
> I expect a section like:
> {
> MGI:105369: {
> symbol: [
> "<em>Cbx</em><em>1</em>"
> ],
> marker_symbol: [
> "<em>Cbx</em><em>1</em>"
> ]
> }
> }
>
>
> I get:
> {
> MGI:105369: { }
> }
>
>
> Can anyone help?
>
> Thanks
>
>


-- 
Regards,
       Asfand Yar Qazi
       Team 87 - High Throughput Gene Targeting
       Wellcome Trust Sanger Institute


-- 
 The Wellcome Trust Sanger Institute is operated by Genome Research 
 Limited, a charity registered in England with number 1021457 and a 
 company registered in England with number 2742969, whose registered 
 office is 215 Euston Road, London, NW1 2BE. 

Mime
View raw message