lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chantal Ackermann <c.ackerm...@it-agenten.com>
Subject Re: Solr upgrade from 1.4 to 3.6
Date Wed, 01 Aug 2012 08:55:21 GMT
Hi Kalyan,

that is becouse SolrJ uses "javabin" as format which has class version numbers in the serialized
objects that do not match. Set the format to XML ("wt" parameter) and it will work (maybe
JSON would, as well).

Chantal
 

Am 31.07.2012 um 20:50 schrieb Manepalli, Kalyan:

> Hi all,
>                We are trying to upgrade our solr instance from 1.4 to 3.6. We use SolrJ
API to fetch the data from index. We see that SolrJ 3.6 version is not compatible with index
generated with 1.4.
> Is this known issue and is there a workaround for this.
> 
> Thanks,
> Kalyan Manepalli
> 


Mime
View raw message