lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Meikle <loo...@gmail.com>
Subject Re: Apache Nutch 1.5.1 + Apache Solr 4.0
Date Sun, 11 Nov 2012 22:04:34 GMT
Hi,

On 8 Nov 2012, at 15:00, Markus Jelsma <markus.jelsma@openindex.io> wrote:

> Hm, i copied the schema from Nutch' trunk verbatim and only had to change the stemmer.
 It seems like you have, for some reason, a float with an extra point dangling around somewhere.
Can you check?

Just building a Nutch 1.5.1 environment and found this too.  It is actually the version number
in the schema.xml[1] and schema-solr4.xml[2]'s for the 1.5.1 branch that is the problem.

In these file the version number reads:
<schema name="nutch" version="1.5.1">

Whereas in trunk[3] it is:
<schema name="nutch" version="1.5">

Obviously as the field is read as a float in the IndexSchema class 1.5.1 will fail due to
the extra float.  A quick change back to 1.5 in the file should solve things.

Cheers,
Dave

[1] http://svn.apache.org/repos/asf/nutch/branches/branch-1.5.1/conf/schema.xml
[2] http://svn.apache.org/repos/asf/nutch/branches/branch-1.5.1/conf/schema-solr4.xml
[3] http://svn.apache.org/repos/asf/nutch/trunk/conf/schema.xml




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message