lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Jelsma <markus.jel...@openindex.io>
Subject RE: Apache Nutch 1.5.1 + Apache Solr 4.0
Date Mon, 12 Nov 2012 14:02:25 GMT
You're in SolrCloud mode, it needs that field. Just put it as explained in the error somewhere
within your <fields> element.
 
 
-----Original message-----
> From:Antony Steiner <ant.steiner@gmail.com>
> Sent: Mon 12-Nov-2012 14:25
> To: solr-user@lucene.apache.org
> Subject: Re: Apache Nutch 1.5.1 + Apache Solr 4.0
> 
> Hello guys
> 
> thank you for your input. I now took the schema from the trunk. This helped
> me: <schema name="nutch" version="1.5"> I had another version which has the
> version number 1.5.1.
> I changed EnglishPorterFilter to PorterStemFilterFactory. But I still keep
> failing at starting up solr. Following error:
> 
> Nov 12, 2012 1:55:58 PM org.apache.solr.update.UpdateLog init
> SEVERE: Unable to use updateLog: _version_field must exist in schema, using
> indexed="true" stored="true" and multiValued="false" (_version_ does not
> exist)
> org.apache.solr.common.SolrException: _version_field must exist in schema,
> using indexed="true" stored="true" and multiValued="false" (_version_ does
> not exist)
> 
> Do I have to add a _version_ field? where do I put that?
> 
> Regards
> Antony
> 

Mime
View raw message