lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Upayavira ...@odoko.co.uk>
Subject Re: Problems getting solr clustering to work
Date Thu, 10 Jan 2013 16:57:37 GMT
Also, you have enable="${solr.clustering.enabled:false}" in there. Are
you setting solr.clustering.enabled=true anywhere? I'd just remove that
bit, you clearly want it enabled.

Upayavira

On Thu, Jan 10, 2013, at 04:23 PM, obi240 wrote:
> I recently started working with the clustering plugin on solr 4.
> I assigned a requsthandler to clustering: /clustering and got the
> following
> errors
> 
> lazy loading errororg.apache.solr.common.SolrException: lazy loading
> error
> at
> org.apache.solr.core.RequestHandlers$LazyRequestHandlerWrapper.getWrappedHandler(RequestHandlers.java:256)
> at
> org.apache.solr.core.RequestHandlers$LazyRequestHandlerWrapper.handleRequest(RequestHandlers.java:238)
> at org.apache.solr.core.SolrCore.execute(SolrCore.java:1699) at
> org.apache.solr.servlet.SolrDispatchFilter.execute(SolrDispatchFilter.java:455)
> at
> org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:276)
> at
> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
> at
> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
> at
> org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:224)
> at
> org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:169)
> at
> org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:168)
> at
> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:100)
> at
> org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:929)
> at
> org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
> at
> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:405)
> at
> org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:964)
> at
> org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:515)
> at
> org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:302)
> at
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
> at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
> at java.lang.Thread.run(Thread.java:722) Caused by:
> org.apache.solr.common.SolrException: Unknown Search Component:
> clustering
> at org.apache.solr.core.SolrCore.getSearchComponent(SolrCore.java:1074)
> at
> org.apache.solr.handler.component.SearchHandler.inform(SearchHandler.java:126)
> at
> org.apache.solr.core.RequestHandlers$LazyRequestHandlerWrapper.getWrappedHandler(RequestHandlers.java:251)
> ... 19 more 500
> 
> 
> Find below my requesthandler and search component in solrconfig:
> <searchComponent name="clustering" 
>                    enable="${solr.clustering.enabled:false}"
>                    class="solr.clustering.ClusteringComponent" >
>     
>     <lst name="engine">
>       
>       <str name="name">default</str>
> 
>       
>       <str
> name="carrot.algorithm">org.carrot2.clustering.lingo.LingoClusteringAlgorithm</str>
> 
>       
>       <str
>       name="LingoClusteringAlgorithm.desiredClusterCountBase">20</str>
>       
>       
>       <str name="carrot.lexicalResourcesDir">clustering/carrot2</str>
> 
>       
>       <str name="MultilingualClustering.defaultLanguage">ENGLISH</str>
>     </lst>
>     <lst name="engine">
>       <str name="name">stc</str>
>       <str
> name="carrot.algorithm">org.carrot2.clustering.stc.STCClusteringAlgorithm</str>
>     </lst>
> 	  <lst name="engine">
>       <str name="name">kmeans</str>
>       <str
> name="carrot.algorithm">org.carrot2.clustering.kmeans.BisectingKMeansClusteringAlgorithm</str>
>     </lst>
>   </searchComponent>
>   
>   
>   
>   
>   
>   <requestHandler name="/clustering" startup="lazy"
>                   enable="${solr.clustering.enabled:true}"
>                   class="solr.SearchHandler">
>     <lst name="defaults">
>       <bool name="clustering">true</bool>
> 
>       <str name="clustering.engine">default</str>
> 	
>       <bool name="clustering.results">true</bool>
>       
>       <str name="carrot.title">subTitle</str>
>       <str name="carrot.url">anchorUrl</str>
>       
>        <str name="carrot.snippet">fullSpeechString</str>
>        
>        <bool name="carrot.produceSummary">true</bool>
> 
>        <bool name="carrot.outputSubClusters">false</bool>
>        <int name="carrot.numDescriptions">20</int>
>  
>       
>     </lst>     
>     <arr name="last-components">
>       <str>clustering</str>
>     </arr>
>   </requestHandler>
> 
> Help please
> 
> 
> 
> 
> --
> View this message in context:
> http://lucene.472066.n3.nabble.com/Problems-getting-solr-clustering-to-work-tp4032251.html
> Sent from the Solr - User mailing list archive at Nabble.com.

Mime
View raw message