lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From eShard <zim...@yahoo.com>
Subject ivy errors trying to build solr from trunk
Date Thu, 10 Jan 2013 19:46:34 GMT
I downloaded the latest from solr.
I applied a patch
cd to solr dir
and I try ant dist
I get these ivy errors
ivy-availability-check:
     [echo] Building analyzers-phonetic...
ivy-fail:
     [echo]      This build requires Ivy and Ivy could not be found in your
ant classpath.
     [echo]      (Due to classpath issues and the recursive nature of the
Lucene/Solr 
     [echo]      build system, a local copy of Ivy can not be used an loaded
dynamically 
     [echo]      by the build.xml)
     [echo]      You can either manually install a copy of Ivy 2.2.0 in your
ant classpath:
     [echo]        http://ant.apache.org/manual/install.html#optionalTasks
     [echo]      Or this build file can do it for you by running the Ivy
Bootstrap target:
     [echo]        ant ivy-bootstrap     
     [echo]      
     [echo]      Either way you will only have to install Ivy one time.
     [echo]      'ant ivy-bootstrap' will install a copy of Ivy into your
Ant User Library:
     [echo]        C:\Users\da24005/.ant/lib
     [echo]      
     [echo]      If you would prefer, you can have it installed into an
alternative 
     [echo]      directory using the
"-Divy_install_path=/some/path/you/choose" option, 
     [echo]      but you will have to specify this path every time you build
Lucene/Solr 
     [echo]      in the future...
     [echo]        ant ivy-bootstrap
-Divy_install_path=/some/path/you/choose
     [echo]        ...
     [echo]        ant -lib /some/path/you/choose clean compile
     [echo]        ...
     [echo]        ant -lib /some/path/you/choose clean compile
     [echo]      If you have already run ivy-bootstrap, and still get this
message, please 
     [echo]      try using the "--noconfig" option when running ant, or
editing your global
     [echo]      ant config to allow the user lib to be loaded.  See the
wiki for more details:
     [echo]        http://wiki.apache.org/lucene-java/HowToContribute#antivy
     [echo]     

BUILD FAILED

i tried the ivy-bootstrap but I still get the same error.
I have the ivy jar in the ant lib directory.

what am I doing wrong? and it says use --noconfig if ivy-bootstrap didn't
work. Well --noconfig is not a valid ant command. where/how do I use it?



--
View this message in context: http://lucene.472066.n3.nabble.com/ivy-errors-trying-to-build-solr-from-trunk-tp4032300.html
Sent from the Solr - User mailing list archive at Nabble.com.

Mime
View raw message