lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Miller <markrmil...@gmail.com>
Subject Re: Problem with Solr replication in solr 4.2
Date Thu, 21 Mar 2013 17:36:47 GMT

On Mar 21, 2013, at 12:08 PM, Rohit Harchandani <rharchu@gmail.com> wrote:

> Hey,
> Currently we are using solr 4.0 with a master slave setup. The data gets
> indexed on the master and then we issue a fetchindex command to replicate
> it on the slave. The slave has a postCommit listener which gets kicked off
> when replication finishes and we depend on this listener to know whn
> replication is done. But when I tried to do the same with 4.2, the commit
> does not seem to be happening. Is this a known issue? is there any other
> way to know that replication is done?

Yeah, we stopped doing this commit because it changes some index meta data and shouldn't be
necessary. I'd open a JIRA issue about being able to listen for replication finishing.

> Also, initially when i tried solr 4.2, i noticed with this setup, i noticed
> that with the fetchIndex command, the fields were downloaded to the temp
> folder, but it was never pulled into the index directory on the slave. The
> only file which made it was the lock file. This problem does not happen
> anymore?

I don't know, does it? Can you file a JIRA with instructions to replicate?

4.2.1 is about to go out, if we are quick, perhaps we can address something here if there
is a problem.

- Mark

> Thanks,
> Rohit


Mime
View raw message