lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neal Ensor <nen...@gmail.com>
Subject Re: SOLR 4.2 SNAPSHOT "There exists no core with name x"
Date Fri, 01 Mar 2013 18:46:55 GMT
Using Chrome (latest) on Mac OSX 10.8.2.  In 4.1.0, I accessed cores
via something like:

http://machine:port/solr/#/corename

and got to the Ping, Query, Schema, etc.  I attempted a similar URL
with my local installation and got the error I mentioned.  I have one
core locally named "master", and made a new one named "testcore" via
the Cores Admin.  Neither could be accessed directly (but could be
searched via the select query URL) yet came up on the Cores Admin page
fine.  The drop-down under the main menu remains empty.

Now that you mentioned browser versions, I JUST tried it using Safari,
and it actually came up; there might be some java script thing that's
giving Chrome indigestion perhaps.  Looking at the Javascript Console
in Chrome I don't see any errors.  The apparently relevant portion of
the source on that page looks like

         <div id="core-selector">
            <select data-placeholder="Core Selector"></select>
          </div>
          <div id="core-menu">
            <ul></ul>
          </div>

empty.  If I can help with any other information, please let me know.
Again, it appears to work on Safari fine hitting the same container,
so must be something Chrome-specific (perhaps something I have
disabled?)


On Fri, Mar 1, 2013 at 1:25 PM, Stefan Matheis <matheis.stefan@gmail.com> wrote:
> Hey Neal
>
> We changed the Navigation after 4.1 was released (https://issues.apache.org/jira/browse/SOLR-4284)
But you're the first one reporting problems with this change (if it's related).
>
> 1) What Browser on which OS are you using?
> 2) And what is/are the Name of your core(s)?
> 3) When you're talking about the "old" core admin, what is the url you're trying to access?
>
> Perhaps you can as well provide Screenshots of the Core-Admin and the Drop-Down (left
side in the Navigation) while it's expanded?
>
> Stefan
>
>
> On Friday, March 1, 2013 at 6:57 PM, Neal Ensor wrote:
>
>> Just pulled down the latest SVN and built it in place to try and
>> upgrade from 4.1 (having replication issues). However, bringing it up
>> with my current core (copied) presents me with the admin page, but an
>> empty drop-down to select specific cores. If I go to "Core Admin" I
>> can see the core, I can issue queries against it, but I cannot go to
>> its statistics, interactive query page, etc. at all. Attempting to
>> access the "old" core admin stuff via direct URL results in the pop-up
>> stating "There exists no core with name myname", even though I can
>> clearly see it there.
>>
>> I even created a brand new core via the core admin interface, and it
>> cannot be seen either. Restarted the container, examined logs, etc.
>> to no avail. Am I missing something obvious here? Any serious
>> deviations between 4.1 and 4.2 (trunk) configuration I need to update?
>> Using tomcat 6.0.36 as a container, freshly-built
>> solr-4.2-SNAPSHOT.war hot off the compiler.
>>
>> Neal Ensor
>> nensor@gmail.com (mailto:nensor@gmail.com)
>
>
>

Mime
View raw message