lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Upayavira ...@odoko.co.uk>
Subject Re: Use of SolrJettyTestBase
Date Thu, 11 Apr 2013 21:01:50 GMT
On Tue, Apr 2, 2013, at 12:21 AM, Chris Hostetter wrote:
> : I've subclassed SolrJettyTestBase, and added a test method (annotated
> : with @test). However, my test method is never called. I see the
> 
> You got an immediate failure from the tests setup, because you don'th ave 
> assertions enabled in your JVM (the Lucene & Solr test frameworks both 
> require assertions enabled to run tests because so many important things 
> can't be sanity checked w/o them)...
> 
> : Test class requires enabled assertions, enable globally (-ea) or for
> : Solr/Lucene subpackages only: com.odoko.ArgPostActionTest
> 
> FYI: in addition to that txt being written to System.err, it would have 
> immediately been thrown as an Exception as well.   (see 
> TestRuleAssertionsRequired.java)

So, I've finally found time to get past the enable assertions thingie.
I've got that sorted. But my test still doesn't stop at breakpoints.

I've got this:

public class ArgPostActionTest extends SolrJettyTestBase {

  @BeforeClass
  public static void beforeTest() throws Exception {
    createJetty(ExternalPaths.EXAMPLE_HOME, null, null);
  }

  @Test
  public void testArgPostAction() throws SolrServerException {
          blah.blah.blah
	  assertEquals(response.getResults().getNumFound(), 1);
  }
}

Neither of these methods get called when I execute the test. Any ideas
what's up?

Upayavira

Mime
View raw message