lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Noble Paul നോബിള്‍ नोब्ळ् <noble.p...@gmail.com>
Subject Re: Replication not working
Date Tue, 11 Jun 2013 12:23:49 GMT
I mean , the log when polling happens when from slave. Not when you issue a
command.


On Tue, Jun 11, 2013 at 5:28 PM, <Thomas.Porocnik@der.net> wrote:

> Log on slave:
>
> 2013-06-11 13:19:08,477 8385607 INFO  [org.apache.solr.core.SolrCore]
> (http-0.0.0.0-31006-1:) [contacts] webapp=/solr path=/replication
> params={indent=true&command=indexversions&wt=json+} status=0 QTime=0
> 2013-06-11 13:19:08,477 8385607 DEBUG
> [org.apache.solr.servlet.SolrDispatchFilter] (http-0.0.0.0-31006-1:)
> Closing out SolrRequest: {indent=true&command=indexversions&wt=json+}
> 2013-06-11 13:22:27,017 8584147 INFO  [org.apache.solr.core.SolrCore]
> (http-0.0.0.0-31006-1:) [contacts] webapp=/solr path=/replication
> params={command=indexversion} status=0 QTime=0
> 2013-06-11 13:22:27,017 8584147 DEBUG
> [org.apache.solr.servlet.SolrDispatchFilter] (http-0.0.0.0-31006-1:)
> Closing out SolrRequest: {command=indexversion}
>
> -----Ursprüngliche Nachricht-----
> Von: Noble Paul നോബിള്‍ नोब्ळ् [mailto:noble.paul@gmail.com]
> Gesendet: Dienstag, 11. Juni 2013 13:41
> An: solr-user@lucene.apache.org
> Betreff: Re: Replication not working
>
> You said polling is happening and nothing is replicated
>
> What do the logs say on slave (Set level to INFO) ?
>
>
>
>
> On Tue, Jun 11, 2013 at 4:54 PM, <Thomas.Porocnik@der.net> wrote:
>
> > Calling indexversion on master gives:
> >  <response>
> >       <lst name="responseHeader">
> >          <int name="status">0</int><int name="QTime">0</int>
> >       </lst>
> >       <long name="indexversion">1370612995391</long>
> >       <long name="generation">53</long>
> >  </response>
> >
> > On Slave:
> >  <response>
> >        <lst name="responseHeader"><int name="status">0</int>
> >        <int name="QTime">0</int></lst>
> >        <long name="indexversion">0</long>
> >        <long name="generation">1</long>
> >  </response>
> >
> > > pollInterval is set to 2 minutes. It is usually long
> >
> > I know ;-)
> >
> >
> > -----Ursprüngliche Nachricht-----
> > Von: Noble Paul നോബിള്‍ नोब्ळ् [mailto:noble.paul@gmail.com]
> > Gesendet: Dienstag, 11. Juni 2013 13:16
> > An: solr-user@lucene.apache.org
> > Betreff: Re: Replication not working
> >
> > can you check with the indexversion command on both mater and slave?
> >
> > pollInterval is set to 2 minutes. It is usually long . So you may need to
> > wait for 2 mins for the replication to kick in
> >
> >
> > On Tue, Jun 11, 2013 at 3:21 PM, <Thomas.Porocnik@der.net> wrote:
> >
> > > Hi all,
> > >
> > >
> > >
> > > we have a setup with multiple cores, loaded via DataImportHandlers.
> > >
> > > Works fine so far.
> > >
> > > Now we are trying to get the replication working (for one core so far).
> > > But the automated replication is never happening.
> > >
> > > Manually triggered replication works!
> > >
> > >
> > >
> > > Environment:
> > >
> > > Solr 4.1 (also tried with 4.3)
> > >
> > > App-Server JBoss 4.3.
> > >
> > > Java 1.6
> > >
> > >
> > >
> > > There are two JBoss instances running on different ports on the same
> box
> > > with their own solr.home directories.
> > >
> > >
> > >
> > > Configuration is done like described in the documentation:
> > >
> > >
> > >
> > > <requestHandler name="/replication" class="solr.ReplicationHandler" >
> > >
> > >          <lst name="master">
> > >
> > >           <str
> name="enable">${de.der.pu.solr.master.enable:false}</str>
> > >
> > >           <str name="replicateAfter">startup</str>
> > >
> > >           <str name="replicateAfter">commit</str>
> > >
> > >           <str name="replicateAfter">optimize</str>
> > >
> > >           <str name="confFiles">stopwords.txt, solrconfig.xml</str>
> > >
> > >          </lst>
> > >
> > >          <lst name="slave">
> > >
> > >      <str name="enable">${de.der.pu.solr.slave.enable:false}</str>
> > >
> > >           <str
> > > name="masterUrl">http://localhost:30006/solr/${solr.core.name}</str>
> > >
> > >           <str name="pollInterfall">00:02:00</str>
> > >
> > >          </lst>
> > >
> > >   </requestHandler>
> > >
> > >
> > >
> > > Basically it looks all fine from the admin-pages.
> > >
> > >
> > >
> > > The polling from the slave is going on but nothing happens.
> > >
> > > We have tried to delete slave index completely and restart both
> servers.
> > > Reimportet the master data several times and so on..
> > >
> > >
> > >
> > > On the masters replication page I see:
> > >
> > > - replication enable: true
> > >
> > > - replicateAfter: commit, startup
> > >
> > > - confFiles: stopwords.txt, solrconfig.xml
> > >
> > >
> > >
> > > On slave side I see:
> > >
> > > -masters version 1370612995391  53   2.56 MB
> > >
> > > -master url:  http://localhost:30006/solr/contacts
> > >
> > > -poling enable: true
> > >
> > >
> > >
> > > And master settings like on master side...
> > >
> > >
> > >
> > > When I enter
> > >
> http://localhost:30006/solr/contacts/replication?command=details&wt=json
> > > &indent=true in the browser the response seems ok:
> > >
> > > {
> > >   "responseHeader":{
> > >     "status":0,
> > >     "QTime":0},
> > >   "details":{
> > >     "indexSize":"2.56 MB",
> > >
> > >
> "indexPath":"D:\\usr\\local\\phx-unlimited\\jboss\\solr_cache\\test_pto_
> > > node1_solr\\contacts\\data\\index/",
> > >     "commits":[[
> > >         "indexVersion",1370612995391,
> > >         "generation",53,
> > >         "filelist",["_1r.fdt",
> > >           "_1r.fdx",
> > >           "_1r.fnm",
> > >           "_1r.nvd",
> > >           "_1r.nvm",
> > >           "_1r.si",
> > >           "_1r_Lucene41_0.doc",
> > >           "_1r_Lucene41_0.pos",
> > >           "_1r_Lucene41_0.tim",
> > >           "_1r_Lucene41_0.tip",
> > >           "segments_1h"]]],
> > >     "isMaster":"true",
> > >     "isSlave":"false",
> > >     "indexVersion":1370612995391,
> > >     "generation":53,
> > >     "master":{
> > >       "confFiles":"stopwords.txt, solrconfig.xml",
> > >       "replicateAfter":["commit",
> > >         "startup"],
> > >       "replicationEnabled":"true",
> > >       "replicableVersion":1370612995391,
> > >       "replicableGeneration":53}},
> > >   "WARNING":"This response format is experimental.  It is likely to
> > > change in the future."}
> > >
> > >
> > >
> > >
> > >
> > > Any idea how we could go on?
> > >
> > >
> > >
> > > Regards
> > >
> > > Thomas
> > >
> > >
> > >
> > >
> >
> >
> > --
> > -----------------------------------------------------
> > Noble Paul
> >
>
>
>
> --
> -----------------------------------------------------
> Noble Paul
>



-- 
-----------------------------------------------------
Noble Paul

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message