lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tony Mullins <tonymullins...@gmail.com>
Subject Re: Apache Nutch data to Solr 4.3 schema issues ?
Date Thu, 13 Jun 2013 13:30:27 GMT
Hi.

I was hoping by replacing Nutch provided schema to my Solr schema ( as the
described by Nutch documentation) would solve all my problems.

So you are suggesting I edit my existing Solr schema and just add the
additional information found in Nutch-Solr schema line by line .

Thanks,
Tony.


On Thu, Jun 13, 2013 at 5:06 PM, Jack Krupansky <jack@basetechnology.com>wrote:

> Look further down in the stack trace in the Solr log for the final "Caused
> By:".
>
> And better to start with the Solr 4.3 schema and config files and then
> merge in your Nutch changes one line at a time.
>
> -- Jack Krupansky
>
> -----Original Message----- From: Tony Mullins
> Sent: Thursday, June 13, 2013 3:56 AM
> To: solr-user@lucene.apache.org
> Subject: Apache Nutch data to Solr 4.3 schema issues ?
>
>
> Hi ,
>
> I am trying to index my Solr 4.3 from Apache Nutch 2.2 data. And for that I
> have copied the schema-solr4.xml from Nutch2.2 runtime/local/conf and
> pasted it to my SolrHome solr/collection1/conf.
>
> My Solr4.3 is hosted in Tomcat. And initially when I tried
> http://localhost:8080/solr/#/**collection1<http://localhost:8080/solr/#/collection1>
> it wasn't working and on further investigation I found _version_ field was
> missing so I added this field as
> <field name="_version_" type="long" indexed="true" stored="true"/> and it
> started working ok.
>
> And now when I try http://localhost:8080/solr/**collection1/browse<http://localhost:8080/solr/collection1/browse>...
it
> shows me errors like
> "HTTP Status 500 - {msg=lazy loading
> error,trace=org.apache.solr.**common.SolrException: lazy loading error at
> org.apache.solr.core.SolrCore$**LazyQueryResponseWriterWrapper**
> .getWrappedWriter(SolrCore.**java:2260)
> at
> org.apache.solr.core.SolrCore$**LazyQueryResponseWriterWrapper**
> .getContentType(SolrCore.java:**2279)
> at
> org.apache.solr.servlet.**SolrDispatchFilter.**writeResponse(**
> SolrDispatchFilter.java:623)
> at
> org.apache.solr.servlet.**SolrDispatchFilter.doFilter(**
> SolrDispatchFilter.java:372)
> at
> org.apache.solr.servlet.**SolrDispatchFilter.doFilter(**
> SolrDispatchFilter.java:155)
> at
> org.apache.catalina.core.**ApplicationFilterChain.**internalDoFilter(**
> ApplicationFilterChain.java:**243)
> at
> org.apache.catalina.core.**ApplicationFilterChain.**doFilter(**
> ApplicationFilterChain.java:**210)
> at ...."
>
> So could you please guide me that whats missing now ? is this again due to
> any schema issue or something else ?
>
> Thanks,
> Tony
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message