lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tuğcem Oral <tugcem.o...@gmail.com>
Subject Re: nutch 1.4, solr 3.4 configuration error
Date Fri, 07 Jun 2013 07:21:47 GMT
I had a similar error. I couldn't find any documentation which nutch and
solr versions are compatible. For instance, we' re using nutch 1.6 on
hadoop 1.0.4 with solrj 3.4.0 and index crawled segments to solr 4.2.0. But
I remember that I could find a compatible version of solrj for nutch 1.4
(because of using hadoop). You can upgrade your nutch from 1.4 to 1.6
easily. And also I suggest you to check for your solrindex-mapping.xml in
your /conf directory.

Best,

Tugcem.


On Fri, Jun 7, 2013 at 12:58 AM, Chris Hostetter
<hossman_lucene@fucit.org>wrote:

> : ./nutch crawl urls -dir myCrawl2 -solr http://localhost:8080 -depth 2
> -topN
>         ...
> : Caused by: org.apache.solr.common.SolrException: Not Found
> :
> : Not Found
> :
> : request: http://localhost:8080/select?q=id:[* TO
> : *]&fl=id&rows=1&wt=javabin&version=2
>         ...
> : Other possibly helpful information:
> : 1) The solr admin screen comes up fine in the browser.
>
> At which URL does the Solr admin screen come up fine in your browser?
>
> Best guess...
>
> 1) you have solr installed such that it uses the webcontext "/solr" but
> you gave the wrong url to nutch (ie: try "-solr
> http://localhost:8080/solr")
>
> 2) you are using multiple collections, and you may need to configure nutch
> to know about which collection you are using (ie: try "-solr
> http://localhost:8080/solr/collection1")
>
> ...if neither of those don't help, i would suggest you follow up with the
> nutch-user list, as the nutch community is probably in the best position
> to help you configure nutch to work with Solr and vice versa)
>
>
> -Hoss
>



-- 
TO

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message