lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jawwad <jawwadmuzaf...@gmail.com>
Subject Solr 4.9.0 Premgen space error
Date Thu, 21 Aug 2014 08:06:06 GMT
Hi,     I am new to Solr. I am trying to index some file via *SolrServer* . I
deployed the war from the latest Solr release on my tomcat 6 server. As
startup I tried indexing some fields using SolrDocument which worked fine.
Then as a next step I started indexing file content using
*ContentStreamUpdateRequest*. Some files were indexed successfully. But I
noticed the tomcat server throws Premgem space error very often especially
in the case of "docx" file. Whenever I try uploading a docx file the tomcat
server most of the times throws Premgen space error and fails. Noticeable
thing is that the file is not a large one, its below 100kbs and my current
startup parameters for Tomcat are: *-Xms1024m -Xmx2048m -XX:PermSize=1024m
-XX:MaxPermSize=2048m*. Plus My system RAM is 6 GBsBelow is my java code:I
am using Windows 7 (64-bit), JDK 1.7.Solrconfig.xml is also attached. Please
can anybody tell me what I might be doing wrong?Thanks in advance.
solrconfig.xml
<http://lucene.472066.n3.nabble.com/file/n4154178/solrconfig.xml>  



--
View this message in context: http://lucene.472066.n3.nabble.com/Solr-4-9-0-Premgen-space-error-tp4154178.html
Sent from the Solr - User mailing list archive at Nabble.com.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message