lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From elisabeth benoit <elisaelisael...@gmail.com>
Subject Re: per field similarity not working with solr 4.2.1
Date Thu, 09 Oct 2014 13:28:27 GMT
ok thanks.


I think something is not working here (I'm quite sure my similarity class
is not beeing used because when I use
SchemaSimilarityFactory and a custom fieldtype similarity definition with
NoTFSimilarity, I don't get the same scoring as when I use NoTFSimilarity
as global similarity; but I'll try to gather more evidences).

Thanks again,
Elisabeth

2014-10-09 15:05 GMT+02:00 Markus Jelsma <markus.jelsma@openindex.io>:

> Well, it is either the output of your calculation or writing something to
> System.out
> Markus
>
>
>
> -----Original message-----
> > From:elisabeth benoit <elisaelisaelisa@gmail.com>
> > Sent: Thursday 9th October 2014 13:31
> > To: solr-user@lucene.apache.org
> > Subject: Re: per field similarity not working with solr 4.2.1
> >
> > Thanks for the information!
> >
> > I've been struggling with that debug output. Any other way to know for
> sure
> > my similarity class is being used?
> >
> > Thanks again,
> > Elisabeth
> >
> > 2014-10-09 13:03 GMT+02:00 Markus Jelsma <markus.jelsma@openindex.io>:
> >
> > > Hi - it should work, not seeing your implemenation in the debug output
> is
> > > a known issue.
> > >
> > >
> > > -----Original message-----
> > > > From:elisabeth benoit <elisaelisaelisa@gmail.com>
> > > > Sent: Thursday 9th October 2014 12:22
> > > > To: solr-user@lucene.apache.org
> > > > Subject: per field similarity not working with solr 4.2.1
> > > >
> > > > Hello,
> > > >
> > > > I am using Solr 4..2.1 and I've tried to use a per field similarity,
> as
> > > > described in
> > > >
> > > >
> > >
> https://apache.googlesource.com/lucene-solr/+/c5bb5cd921e1ce65e18eceb55e738f40591214f0/solr/core/src/test-files/solr/collection1/conf/schema-sim.xml
> > > >
> > > > so in my schema I have
> > > >
> > > > <schema name="search" version="1.4">
> > > > <similarity class="solr.SchemaSimilarityFactory"/>
> > > >
> > > > and a custom similarity in fieldtype definition
> > > >
> > > >     <fieldType name="text" class="solr.TextField"
> > > > positionIncrementGap="100">
> > > >      <similarity
> > > > class="com.company.lbs.solr.search.similarity.NoTFSimilarity"/>
> > > >        <analyzer type="index">
> > > > ...
> > > >
> > > > but it is not working
> > > >
> > > > when I send a request with debugQuery=on, instead of [
> > > > NoTFSimilarity], I see []
> > > >
> > > > or to give an example, I have
> > > >
> > > >
> > > > weight(catchall:bretagn in 2575) []
> > > >
> > > > instead of weight(catchall:bretagn in 2575) [NoTFSimilarity]
> > > >
> > > > Anyone has a clue what I am doing wrong?
> > > >
> > > > Best regards,
> > > > Elisabeth
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message