lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sindre Fiskaa <...@dips.no>
Subject Re: SolrCloud with client ssl
Date Thu, 09 Oct 2014 12:50:37 GMT

This is output from overseer with severity to INFO

942420 [http-nio-443-exec-7] INFO
org.apache.solr.handler.admin.CollectionsHandler  ? Creating Collection :
numShards=3&createNodeSet=vt-searchln03:443_solr,vt-searchln04:443_solr,vt-
searchln01:443_solr,vt-searchln02:443_solr,vt-searchln05:443_solr,vt-search
ln06:443_solr&name=multisharding2&replicationFactor=2&action=CREATE
942472 [zkCallback-2-thread-3] INFO
org.apache.solr.common.cloud.ZkStateReader  ? A cluster state change:
WatchedEvent state:SyncConnected type:NodeDataChanged
path:/clusterstate.json, has occurred - updating... (live nodes size: 8)
942639 [zkCallback-2-thread-3] INFO
org.apache.solr.cloud.DistributedQueue  ? LatchChildWatcher fired on path:
/overseer/collection-queue-work/qnr-0000000290 state: SyncConnected type
NodeDataChanged
942644 [http-nio-443-exec-7] INFO
org.apache.solr.servlet.SolrDispatchFilter  ? [admin] webapp=null
path=/admin/collections
params={numShards=3&createNodeSet=vt-searchln03:443_solr,vt-searchln04:443_
solr,vt-searchln01:443_solr,vt-searchln02:443_solr,vt-searchln05:443_solr,v
t-searchln06:443_solr&name=multisharding2&replicationFactor=2&action=CREATE
} status=0 QTime=224




On 09.10.14 11:59, "Jan Høydahl" <jan.asf@cominvent.com> wrote:

>We also have another bug here, that the request responds with status=0,
>which means success, when only parts of the distributed request
>succeeded, but not all. That probably warrants its own JIRA issue.
>
>The logs you printed are from the client. Can you also dig up the
>corresponding logs from the Overseer node, we need to find what kind of
>IOException is happening and where.
>
>--
>Jan Høydahl, search solution architect
>Cominvent AS - www.cominvent.com
>
>8. okt. 2014 kl. 16:08 skrev Sindre Fiskaa <sfi@dips.no>:
>
>> Yes, running SolrCloud without SSL it works fine with the createNodeSet
>> param. I run this with Tomcat application server and 443 enabled.
>> Although I receive this error message the collection and the shards gets
>> created and the clusterstate.json updated, but the cores are missing. I
>> manual add them one by one in the admin console so I get my cloud up
>> running and the solr-nodes are able to talk to each other - no
>>certificate
>> issues or SSL handshake error between the nodes.
>> 
>> curl -E solr-ssl.pem:secret12 -k
>> 
>>'https://vt-searchln03:443/solr/admin/collections?action=CREATE&numShards
>>=3
>> 
>>&replicationFactor=2&name=multisharding&createNodeSet=vt-searchln03:443_s
>>ol
>> 
>>r,vt-searchln04:443_solr,vt-searchln01:443_solr,vt-searchln02:443_solr,vt
>>-s
>> earchln05:443_solr,vt-searchln06:443_solr'
>> 
>> <?xml version="1.0" encoding="UTF-8"?>
>> <response>
>> <lst name="responseHeader"><int name="status">0</int><int
>> name="QTime">206</int></lst><lst
>> 
>>name="failure"><str>org.apache.solr.client.solrj.SolrServerException:IOEx
>>ce
>> ption occured when talking to server at: https://vt-searchln03:443/solr
>> 
>><https://vt-searchln03/solr></str><str>org.apache.solr.client.solrj.SolrS
>>er
>> verException:IOException occured when talking to server at:
>> https://vt-searchln04:443/solr
>> 
>><https://vt-searchln04/solr></str><str>org.apache.solr.client.solrj.SolrS
>>er
>> verException:IOException occured when talking to server at:
>> https://vt-searchln06:443/solr
>> 
>><https://vt-searchln06/solr></str><str>org.apache.solr.client.solrj.SolrS
>>er
>> verException:IOException occured when talking to server at:
>> https://vt-searchln05:443/solr
>> 
>><https://vt-searchln05/solr></str><str>org.apache.solr.client.solrj.SolrS
>>er
>> verException:IOException occured when talking to server at:
>> https://vt-searchln01:443/solr
>> 
>><https://vt-searchln01/solr></str><str>org.apache.solr.client.solrj.SolrS
>>er
>> verException:IOException occured when talking to server at:
>> https://vt-searchln02:443/solr <https://vt-searchln02/solr></str></lst>
>> </response>
>> 
>> 
>> -Sindre
>> 
>> On 08.10.14 15:14, "Jan Høydahl" <jan.asf@cominvent.com> wrote:
>> 
>>> Hi,
>>> 
>>> I answered at https://issues.apache.org/jira/browse/SOLR-6595:
>>> 
>>> * Does it work with createNodeSet when using plain SolrCloud without
>>>SSL?
>>> * Please provide the exact CollectionApi request you used when it
>>>failed,
>>> so we can see if the syntax is correct. Also, is 443 your secure port
>>> number in Jetty/Tomcat?
>>> 
>>> ...but perhaps keep the conversation going here until it is a confirmed
>>> bug :)
>>> 
>>> --
>>> Jan Høydahl, search solution architect
>>> Cominvent AS - www.cominvent.com
>>> 
>>> 7. okt. 2014 kl. 06:57 skrev Sindre Fiskaa <sfi@dips.no>:
>>> 
>>>> Followed the description
>>>> https://cwiki.apache.org/confluence/display/solr/Enabling+SSL and
>>>> generated a self signed key pair. Configured a few solr-nodes and used
>>>> the collection api to crate a new collection. I get error message when
>>>> specify the nodes with the createNodeSet param. When I don't use
>>>> createNodeSet param the collection gets created without error on
>>>>random
>>>> nodes. Could this be a bug related to the createNodeSet param?
>>>> 
>>>> 
>>>> <response>
>>>> <lst name="responseHeader"><int name="status">0</int><int
>>>> name="QTime">185</int></lst><lst
>>>> 
>>>>name="failure"><str>org.apache.solr.client.solrj.SolrServerException:IO
>>>>Ex
>>>> ception occured when talking to server
>>>> 
>>>>at:https://vt-searchln04:443/solr</str></lst><https://vt-searchln04/sol
>>>>r%
>>>> 3C/str%3E%3C/lst%3E>
>>>> </response>
>>> 
>> 
>


Mime
View raw message