lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From onyourmark <william...@gmail.com>
Subject first time user
Date Sat, 13 Dec 2014 00:05:40 GMT
Hi. I tried setting up and running solr on a pc. Then I tried to index a
document that was semicolon delimited although it has a file extension of
.csv and got the following:

C:\Users\Owner\Downloads\SOLR\solr-4.10.2>java -classpath
dist/solr-core-4.10.2.jar -Dauto org.apache.solr.util.SimplePostTool
example/exampledocs/tweets_01-01-12_12-00-02.csv
SimplePostTool version 1.5
Posting files to base url http://localhost:8983/solr/update..
Entering auto mode. File endings considered are
xml,json,csv,pdf,doc,docx,ppt,pptx,xls,xlsx,odt,odp,ods,ott,otp,ots,rtf,htm,html,txt,log
POSTing file tweets_01-01-12_12-00-02.csv (text/csv)
SimplePostTool: WARNING: Solr returned an error #400 (Bad Request) for url:
http://localhost:8983/solr/update
SimplePostTool: WARNING: Response: <?xml version="1.0" encoding="UTF-8"?>
<response>
<lst name="responseHeader"><int name="status">400</int><int
name="QTime">0</int></lst><lst name="error"><str name="msg">CSVLoader:
input=null, line=1,expected 1 values but got 2
        values={'662641699;11:55:03;01;01;2012;EMILYWRIGHT9;RT
@alandavidharris: Great bargains on our 8ft tall LED outdoor cherry tree.
Now half price at £149.00 http://t.co/PJHQTUnV;DEVON','
ENGLAND;;;;;0;0',}</str><int name="co
de">400</int></lst>
</response>
SimplePostTool: WARNING: IOException while reading response:
java.io.IOException: Server returned HTTP response code: 400 for URL:
http://localhost:8983/solr/update
1 files indexed.
COMMITting Solr index changes to http://localhost:8983/solr/update..
Time spent: 0:00:00.078

C:\Users\Owner\Downloads\SOLR\solr-4.10.2>

Then I tried a query for 'eyebrows' which I saw was in the .csv file like
this:

at http://localhost:8983/solr/#/collection1/query

http://localhost:8983/solr/collection1/select?q=eyebrows&wt=json&indent=true
but I got:

{
  "responseHeader": {
    "status": 0,
    "QTime": 0,
    "params": {
      "q": "eyebrows",
      "indent": "true",
      "wt": "json",
      "_": "1418362651114"
    }
  },
  "response": {
    "numFound": 0,
    "start": 0,
    "docs": []
  }
}

Can anyone suggest what I have done wrong and how I can index this type of
file?
Thank you.



--
View this message in context: http://lucene.472066.n3.nabble.com/first-time-user-tp4174121.html
Sent from the Solr - User mailing list archive at Nabble.com.

Mime
View raw message