lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <apa...@elyograg.org>
Subject Re: Mixing 4.x SolrJ and Solr.war - compatible?
Date Thu, 01 Jan 2015 19:12:36 GMT
On 1/1/2015 6:34 AM, Gili Nachum wrote:
> So, It seems I can't upgrade Solr beyond 4.7 as long as I'm running SolrJ
> on Java6 JVM.
> With any luck I might be able to compile SolrJ that's newer than 4.7 with
> Java6. I'll check that next.
> Thanks Shawn. That's very helping!

Solr 4.8 and later (compared to 4.7) have a very large number of code
changes that will not compile under Java 6.  It would be a *major*
undertaking to change those back.  When the project declared that Java 7
was the minimum version, we weren't just making a statement ... it
really did become the minimum requirement.

Oracle has stopped providing support for Java 6.  Java 7 will also reach
end of support in April 2015, so you might actually want to consider
moving to Java 8, which has even more performance improvements over Java 7.

Along with the latest Java 7 or Java 8, you should probably change your
garbage collection tuning to G1.  With a lot of invaluable help from
Oracle employees, I've worked out a good set of parameters:

https://wiki.apache.org/solr/ShawnHeisey#GC_Tuning

Thanks,
Shawn


Mime
View raw message