lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <apa...@elyograg.org>
Subject Re: Solr unit tests intermittently fail with error: java.lang.NoClassDefFoundError: org/eclipse/jetty/util/security/CertificateUtils
Date Tue, 13 Jan 2015 23:02:30 GMT
On 1/13/2015 2:50 PM, brian4 wrote:
> The problem is the jetty-util version included in the Solr build is 6.1.26,
> but this particular package is from version 7+.  Looks like it is a bug in
> the build files for Solr.
>
> I fixed it by downloading jetty 7 separately and manually adding
> jetty-util-7.6.16.v20140903.jar to the end of my classpath.

The jetty version included in the Solr build for 4.x is
8.1.10.v20130312.  There is a dependency in *Lucene* for 6.1.26, but
it's a completely optional Lucene add-on that is not used in *Solr*.

Thanks,
Shawn


Mime
View raw message