lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "david.w.smiley@gmail.com" <david.w.smi...@gmail.com>
Subject Re: trouble running indexer with Solr spatial
Date Tue, 27 Jan 2015 21:10:57 GMT
Hi vit,

FYI that’s the old wiki and it contains a notice in red at the top that you
should refer to its replacement at:
https://cwiki.apache.org/confluence/display/solr/Spatial+Search  That said,
there are some small details that haven’t been migrated but there is
outdated info too so beware.

The error you see is weird.  I suspect you are not using Solr “normally”…
perhaps you have added Solr and some of its dependencies to your Java
classpath in your IDE and have run into problems.

~ David Smiley
Freelance Apache Lucene/Solr Search Consultant/Developer
http://www.linkedin.com/in/davidwsmiley

On Tue, Jan 27, 2015 at 3:07 PM, vit <bulgakov_v@yahoo.com> wrote:

> I am using Solr 4.2
>
> I added
> <fieldType name="location_rpt"
> class="solr.SpatialRecursivePrefixTreeFieldType"
>
> according to
> <a href="http://">
> https://wiki.apache.org/solr/SolrAdaptersForLuceneSpatial4
>  and have spatial4j-0.3.jar in my project.
>
> When running the indexer I started getting this error:
>
> java.lang.NoClassDefFoundError: com/google/common/cache/CacheBuilder
>         at
>
> org.apache.solr.schema.AbstractSpatialFieldType.<init>(AbstractSpatialFieldType.java:82)
>         at
>
> org.apache.solr.schema.AbstractSpatialPrefixTreeFieldType.<init>(AbstractSpatialPrefixTreeFieldType.java:32)
>         at
>
> org.apache.solr.schema.SpatialRecursivePrefixTreeFieldType.<init>(SpatialRecursivePrefixTreeFieldType.java:28)
>         at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
> Method)
>         at
>
> sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
>         at
>
> sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
>         at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
>         at java.lang.Class.newInstance0(Class.java:357)
>         at java.lang.Class.newInstance(Class.java:310)
>         at
>
> org.apache.solr.core.SolrResourceLoader.newInstance(SolrResourceLoader.java:470)
>         at
>
> org.apache.solr.core.SolrResourceLoader.newInstance(SolrResourceLoader.java:458)
>         at
>
> org.apache.solr.schema.FieldTypePluginLoader.create(FieldTypePluginLoader.java:81)
>         at
>
> org.apache.solr.schema.FieldTypePluginLoader.create(FieldTypePluginLoader.java:43)
>         at
>
> org.apache.solr.util.plugin.AbstractPluginLoader.load(AbstractPluginLoader.java:151)
>         at
> org.apache.solr.schema.IndexSchema.readSchema(IndexSchema.java:374)
>         at org.apache.solr.schema.IndexSchema.<init>(IndexSchema.java:122)
>         at org.apache.solr.core.SolrCore.<init>(SolrCore.java:684)
>         at org.apache.solr.core.SolrCore.<init>(SolrCore.java:618)
>
>
>
> --
> View this message in context:
> http://lucene.472066.n3.nabble.com/trouble-running-indexer-with-Solr-spatial-tp4182359.html
> Sent from the Solr - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message