lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gili Nachum <gilinac...@gmail.com>
Subject Re: Mixing 4.x SolrJ and Solr.war - compatible?
Date Thu, 01 Jan 2015 13:34:35 GMT
So, It seems I can't upgrade Solr beyond 4.7 as long as I'm running SolrJ
on Java6 JVM.
With any luck I might be able to compile SolrJ that's newer than 4.7 with
Java6. I'll check that next.
Thanks Shawn. That's very helping!

On Wed, Dec 31, 2014 at 6:54 PM, Shawn Heisey <apache@elyograg.org> wrote:

> On 12/31/2014 6:23 AM, Gili Nachum wrote:
> > Can I use SolrJ v4.7 with the latest 4.x Solr.war?
> > Should I switch the writer from Javabin, back to XML to ensure
> > compatibility?
> >
> http://wiki.apache.org/solr/Solrj#SolrJ.2FSolr_cross-version_compatibility
> >
> > I'm using CloudSolrServer. My client is running on Java6 so I can't go
> > beyond 4.7.
>
> If you're running SolrCloud, I would not try it.  SolrCloud is evolving
> very quickly and so many things have changed that running mismatched
> versions is likely to break.  I have tried CloudSolrServer from 4.6.0
> against a SolrCloud running 4.2.1, and a simple query will not work
> because of changes in the data contained in zookeeper.
>
> If you're not using CloudSolrServer, it should work very well even with
> a wide version discrepancy.
>
> Switching to XML is not required.  The javabin version has only changed
> once, in version 3.1.0.  It has been stable since that time.
>
> Thanks,
> Shawn
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message