lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: Solr fails to start with log file not found error
Date Tue, 13 Jan 2015 15:42:43 GMT
By any chance are you trying to start Solr as a different user when
this happens? I'm
wondering if there's a permissions issue here....

Wild guess.

On Tue, Jan 13, 2015 at 12:37 AM, Graeme Pietersz <graeme@pietersz.net> wrote:
> I get this error when starting Solr using the script in bin/solr
>
> tail cannot open `[path]/logs/solr.log’ for reading: No such file or directory
>
> It does not happen every time, but it does happen a lot. It sometimes clears up after
a while.
>
> I have tried creating an empty file, but solr then just says:
>
> Backing up [path]/logs/solr.log
>
> And repeats the same error.
>
> I am guessing the problem is that it cannot get the error from the log file because the
log file has not been created yet, but then how do I debug this?
>
> Running  Solr 4.10.2 on Debian 7 using Jetty with the default IcedTea 2.5.3 java version
1.7.0_65
>
> Thanks for any help or pointers.

Mime
View raw message