lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: Solr numFound > 0 but doc list empty in Solr Cloud setup
Date Fri, 16 Jan 2015 17:56:18 GMT
Any chance that you've defined &rows=0 in your handler? Or is it possible
that you have not set stored="true" for any of your fields?

Best,
Erick

On Fri, Jan 16, 2015 at 9:46 AM, Jaikit Savla
<jaikit.savla@yahoo.com.invalid> wrote:
> I am using below tutorial for Solr Cloud setup with 2 shards
> http://wiki.apache.org/solr/SolrCloud#Example_A:_Simple_two_shard_cluster
>
>
> I am able to get the default set up working. However, I have a requirement where my index
is not in default location (data/index) and hence when I start jvm for each shard I run with
-Dsolr.data.dir=<custom index path> . Now when I query I get results with numFound >
0 but doc list is always empty.
>
> I verified that my index does have fields stored and indexed. Anyone else faced similar
issue or have an idea on what I am missing ? Verified that by loading single core.
>
> Appreciate any help.
>
> request:
>
> http://localhost:9999/solr/collection1/select?q=body%3A%22to%22&wt=json&indent=true&shards=http://localhost:9999/solr/collection1
>
>
> response:
> { "responseHeader": { "status": 0, "QTime": 18, "params": { "shards": "http://localhost:9999/solr/collection1",
"indent": "true", "q": "body:\"to\"", "_": "1421390858638", "wt": "json" } }, "response":
{ "numFound": 2564, "start": 0, "maxScore": 0.4523638, "docs": [] } }

Mime
View raw message