lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshi, Shital" <Shital.Jo...@gs.com>
Subject IndexFormatTooNewException
Date Wed, 28 Jan 2015 20:34:10 GMT
Hi,

We upgraded our cluster to Solr 4.10.0 for couple days and again reverted back to 4.8.0. However
the dashboard still shows Solr 4.10.0. Do you know why?
*       solr-spec 4.10.0
*       solr-impl 4.10.0 1620776
*       lucene-spec 4.10.0
*       lucene-impl 4.10.0 1620776

We recently added new shards to our cluster and dashboard shows correct Solr version (4.8.0)
for these new shards. We copied index from one of old shards (where it is showing 4.10.0 on
dashboard) to this new shard and we see this error upon start up. How do we get rid of this
error?

Caused by: org.apache.lucene.index.IndexFormatTooNewException: Format version is not supported
(resource: BufferedChecksumIndexInput(MMapIndexInput(path="/local/data/solr13/index.20140919180209018/segments_1tzz"))):
3 (needs to be between 0 and 2)
        at org.apache.lucene.codecs.CodecUtil.checkHeaderNoMagic(CodecUtil.java:156)
        at org.apache.lucene.index.SegmentInfos.read(SegmentInfos.java:335)
        at org.apache.lucene.index.SegmentInfos$1.doBody(SegmentInfos.java:416)
        at org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run(SegmentInfos.java:864)
        at org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run(SegmentInfos.java:710)
        at org.apache.lucene.index.SegmentInfos.read(SegmentInfos.java:412)
        at org.apache.lucene.index.IndexWriter.<init>(IndexWriter.java:749)



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message