lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zheng Lin Edwin Yeo <edwinye...@gmail.com>
Subject Re: Unable to perform search query after changing uniqueKey
Date Tue, 31 Mar 2015 03:59:44 GMT
Latest information that I've found for this is that the error only occurs
for shard2.

If I do a search for just shard1, those records that are assigned to shard1
will be able to be displayed. Only when I search for shard2 will the
NullPointerException error occurs. Previously I was doing a search for both
shards.

Is there any settings that I required to do for shard2 in order to solve
this issue? Currently I have not made any changes to the shards since I
created it using
http://localhost:8983/solr/admin/collections?action=CREATE&name=nps1&numShards=2&collection.configName=collection1


Regards,
Edwin

On 31 March 2015 at 09:42, Zheng Lin Edwin Yeo <edwinyeozl@gmail.com> wrote:

> Hi Erick,
>
> I've changed the uniqueKey from id to Item No.
>
> <uniqueKey>Item No</uniqueKey>
>
>
> Below are my definitions for both the id and Item No.
>
> <field name="id" type="string" indexed="true" stored="true"
> required="false" multiValued="false" />
> <field name="Item No" type="text_general" indexed="true" stored="true"/>
>
> Regards,
> Edwin
>
>
> On 30 March 2015 at 23:05, Erick Erickson <erickerickson@gmail.com> wrote:
>
>> Well, let's see the definition of your ID field, 'cause I'm puzzled.
>>
>> It's definitely A Bad Thing to have it be any kind of tokenized field
>> though, but that's a shot in the dark.
>>
>> Best,
>> Erick
>>
>> On Mon, Mar 30, 2015 at 2:17 AM, Zheng Lin Edwin Yeo
>> <edwinyeozl@gmail.com> wrote:
>> > Hi Mostafa,
>> >
>> > Yes, I've defined all the fields in schema.xml. It is able to work on
>> the
>> > version without SolrCloud, but it is not working for the one with
>> SolrCloud.
>> > Both of them are using the same schema.xml.
>> >
>> > Regards,
>> > Edwin
>> >
>> >
>> >
>> > On 30 March 2015 at 14:34, Mostafa Gomaa <mostafa.gomaa89@gmail.com>
>> wrote:
>> >
>> >> Hi Zheng,
>> >>
>> >> It's possible that there's a problem with your schema.xml. Are all
>> fields
>> >> defined and have appropriate options enabled?
>> >>
>> >> Regards,
>> >>
>> >> Mostafa.
>> >>
>> >> On Mon, Mar 30, 2015 at 7:49 AM, Zheng Lin Edwin Yeo <
>> edwinyeozl@gmail.com
>> >> >
>> >> wrote:
>> >>
>> >> > Hi Erick,
>> >> >
>> >> > I've tried that, and removed the data directory from both the
>> shards. But
>> >> > the same problem still occurs, so we probably can rule out the
>> "memory"
>> >> > issue.
>> >> >
>> >> > Regards,
>> >> > Edwin
>> >> >
>> >> > On 30 March 2015 at 12:39, Erick Erickson <erickerickson@gmail.com>
>> >> wrote:
>> >> >
>> >> > > I meant shut down Solr and physically remove the entire data
>> >> > > directory. Not saying this is the cure, but it can't hurt to rule
>> out
>> >> > > the index having "memory"...
>> >> > >
>> >> > > Best,
>> >> > > Erick
>> >> > >
>> >> > > On Sun, Mar 29, 2015 at 6:35 PM, Zheng Lin Edwin Yeo
>> >> > > <edwinyeozl@gmail.com> wrote:
>> >> > > > Hi Erick,
>> >> > > >
>> >> > > > I used the following query to delete all the index.
>> >> > > >
>> >> > > > http://localhost:8983/solr/update?stream.body=
>> >> > > <delete><query>*:*</query></delete>
>> >> > > http://localhost:8983/solr/update?stream.body=<commit/>
>> >> > > >
>> >> > > >
>> >> > > > Or is it better to physically delete the entire data directory?
>> >> > > >
>> >> > > >
>> >> > > > Regards,
>> >> > > > Edwin
>> >> > > >
>> >> > > >
>> >> > > > On 28 March 2015 at 02:27, Erick Erickson <
>> erickerickson@gmail.com>
>> >> > > wrote:
>> >> > > >
>> >> > > >> You say you re-indexed, did you _completely_ remove the
data
>> >> directory
>> >> > > >> first, i.e. the parent of the "index" and, maybe, "tlog"
>> >> directories?
>> >> > > >> I've occasionally seen remnants of old definitions "pollute"
>> the new
>> >> > > >> one, and since the <uniqueKey> key is so fundamental
I can see
>> it
>> >> > > >> being a problem.
>> >> > > >>
>> >> > > >> Best,
>> >> > > >> Erick
>> >> > > >>
>> >> > > >> On Fri, Mar 27, 2015 at 1:42 AM, Andrea Gazzarini <
>> >> > > a.gazzarini@gmail.com>
>> >> > > >> wrote:
>> >> > > >> > Hi Edwin,
>> >> > > >> > please provide some other detail about your context,
(e.g.
>> >> complete
>> >> > > >> > stacktrace, query you're issuing)
>> >> > > >> >
>> >> > > >> > Best,
>> >> > > >> > Andrea
>> >> > > >> >
>> >> > > >> >
>> >> > > >> > On 03/27/2015 09:38 AM, Zheng Lin Edwin Yeo wrote:
>> >> > > >> >>
>> >> > > >> >> Hi everyone,
>> >> > > >> >>
>> >> > > >> >> I've changed my uniqueKey to another name, instead
of using
>> id,
>> >> on
>> >> > > the
>> >> > > >> >> schema.xml.
>> >> > > >> >>
>> >> > > >> >> However, after I have done the indexing (the
indexing is
>> >> > successful),
>> >> > > >> I'm
>> >> > > >> >> not able to perform a search query on it. I
gives the error
>> >> > > >> >> java.lang.NullPointerException.
>> >> > > >> >>
>> >> > > >> >> Is there other place which I need to configure,
besides
>> changing
>> >> > the
>> >> > > >> >> uniqueKey field in scheam.xml?
>> >> > > >> >>
>> >> > > >> >> Regards,
>> >> > > >> >> Edwin
>> >> > > >> >>
>> >> > > >> >
>> >> > > >>
>> >> > >
>> >> >
>> >>
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message