lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aman Tandon <amantandon...@gmail.com>
Subject Re: SolrCloud: Chroot error
Date Tue, 10 Mar 2015 12:10:13 GMT
Thanks Shawn, I tried it with single string but still no success.

So currently i am running it without chroot and it is working fine.

With Regards
Aman Tandon

On Mon, Mar 9, 2015 at 9:46 PM, Shawn Heisey <apache@elyograg.org> wrote:

> On 3/9/2015 10:03 AM, Aman Tandon wrote:
> > Thanks for replying, Just to send the mail, I replaced the IP addresses
> > with the imaginary hostname, now the command is
> >
> > *./solr start -c -z localhost:2181,abc.com:2181
> > <http://abc.com:2181>,xyz.com:2181/home/aman/solrcloud/solr_zoo
> > <http://xyz.com:2181/home/aman/solrcloud/solr_zoo> -p 4567*
>
> The same URL replacement is still happening.  I think I know what you
> are doing, but I was hoping to have a clean string just to make sure.
>
> You should not be using "localhost" in the zkHost string unless there is
> only one zk server, or you are trying to start the entire cluster on one
> machine.  All of your Solr machines should have identical zkHost
> parameters.  That is not possible if they are separate machines and you
> use localhost.
>
> Your chroot should be very simple, as I mentioned in the other email.
> Using "/solr" is appropriate if you won't be sharing the zookeeper
> ensemble with multiple SolrCloud clusters.  The filesystem layout of
> your zookeeper install (bin, data, logs, etc) is NOT relevant for this
> chroot.  It exists only within the zookeeper database.
>
> Thanks,
> Shawn
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message