lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Reuschling <christian.reuschl...@gmail.com>
Subject Generating json response in custom requestHandler (xml is working)
Date Thu, 02 Apr 2015 16:51:15 GMT
Hi,

I managed it to create a small custom requestHandler, and filled the response parameter with
 some
static values in the structure I want to have later.

I can invoke the requestHander from the browser and get nicely xml with the data and structure
I
had specified - so far so good. Here is the xml response:


<response>
	<lst name="responseHeader">
		<int name="status">0</int>
		<int name="QTime">17</int>
	</lst>
	<lst name="response">
		<double name="doubleAtt1">13.0</double>
		<double name="doubleAtt2">14.0</double>
		<int name="intAtt1">15</int>
		<double name="doubleAtt3">16.0</double>
		<double name="doubleAtt4">17.0</double>
		<arr name="slices">
			<lst>
				<double name="doubleAtt1">13.0</double>
				<double name="doubleAtt2">14.0</double>
				<int name="intAtt1">15</int>
				<double name="doubleAtt5">16.0</double>
				<double name="doubleAtt6">17.0</double>
				<arr name="ids">
					<str>id1</str>
					<str>id2</str>
					<str>id3</str>
					<str>id4</str>
				</arr>
			</lst>
			<lst>
				<double name="doubleAtt1">13.0</double>
				<double name="doubleAtt2">14.0</double>
				<int name="intAtt1">15</int>
				<double name="doubleAtt5">16.0</double>
				<double name="doubleAtt6">17.0</double>
				<arr name="ids">
					<str>id1</str>
					<str>id2</str>
					<str>id3</str>
					<str>id4</str>
				</arr>
			</lst>
		</arr>
	</lst>
</response>


Now I simply add &wt=json to the invocation. Sadly I get a

HTTP ERROR 404

Problem accessing /solr/etr_base_core/trends&wt=json. Reason:

    Not Found


I had the feeling that the response format is transparent for me when I write a custom
requestHandler. But it seems I've overseen something.

Does anybody have an idea?


Regards

Christian

Mime
View raw message