lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <apa...@elyograg.org>
Subject Re: apache 5.1.0 under apache web server
Date Mon, 04 May 2015 19:12:11 GMT
On 5/4/2015 1:04 PM, Tim Dunphy wrote:
> I need to run solr 5.1.0 on port 80 with some basic apache authentication.
> Normally, under earlier versions of solr I would set it up to run under
> tomcat, then connect it to apache web server using mod_jk.
>
> However 5.1.0 seems totally different. I see that tomcat support has been
> removed from the latest versions. So how do I set this up in front of
> apache web server? I need to get this running on port 443 with SSL and
> something at least equivalent to basic apache auth.
>
> I really wish this hadn't changed because I could set this up under the old
> method rather easily and quickly. Sigh..
>
> But thank you for your advice!

The container in the default 5.x install is a completely unmodified
Jetty 8.x (soon to be Jetty 9.x) with a stripped and optimized config. 
The config for Jetty is similar to tomcat, you just need to figure out
how to make it work with Apache like you would with Tomcat.

Incidentially, at least for right now, you CAN still take the .war file
out of the jetty install and put it in Tomcat just like you would have
with a 4.3 or later version.  We are planning on making that impossible
in a later 5.x version, but for right now, it is still possible.

Thanks,
Shawn


Mime
View raw message