lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <apa...@elyograg.org>
Subject Re: Solr not getting Start. Error : Could not find the main class: org.apache.solr.util.SolrCLI
Date Wed, 06 May 2015 13:02:26 GMT
On 5/6/2015 6:37 AM, Markus Heiden wrote:
> UnsupportedClassVersionError means you have an old JDK. Use a more recent
> one.

Specifically, "Unsupported major.minor version 51.0" means you are
trying to use Java 6 (1.6.0) to run a program that requires Java 7
(1.7.0).  Solr 4.8 and later (including the 5.x versions) requires Java 7.

If you're looking for the absolute minimum requirements, you only need
the JRE, not the JDK.

Thanks,
Shawn


Mime
View raw message