lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From shacky <shack...@gmail.com>
Subject Re: ZooKeeperException: Could not find configName for collection
Date Fri, 08 May 2015 12:49:13 GMT
Thank you Erick for your answer!
I just tried to restart the first node and now the error is not yet there!
Sorry for my too-early email :-)
Bye!

2015-05-06 17:05 GMT+02:00 Erick Erickson <erickerickson@gmail.com>:
> Have you looked arond at your directories on disk? I'm _not_ talking
> about the admin UI here. The default is "core discovery" mode, which
> recursively looks under solr_home and thinks there's a core wherever
> it finds a "core.properties" file. If you find such a thing, rename it
> or remove the directory.
>
> Another alternative would be to push a configset named "new_core" up
> to Zookeeper, that might allow you to see (and then delete) the
> collection new_core belongs to.
>
> It looks like you tried to use the admin UI to create a core and it's
> all local or something like that.
>
> Best,
> Erick
>
> On Wed, May 6, 2015 at 4:00 AM, shacky <shacky83@gmail.com> wrote:
>> Hi list.
>>
>> I created a new collection on my new SolrCloud installation, the new
>> collection is shown and replicated on all three nodes, but on the
>> first node (only on this one) I get this error:
>>
>> new_core: org.apache.solr.common.cloud.ZooKeeperException:org.apache.solr.common.cloud.ZooKeeperException:
>> Could not find configName for collection new_core found:null
>>
>> I cannot see any core named "new_core" on that node, and I also tried
>> to remove it:
>>
>> root@index1:/opt/solr# ./bin/solr delete -c new_core
>> Connecting to ZooKeeper at zk1,zk2,zk3
>> ERROR: Collection new_core not found!
>>
>> Could you help me, please?
>>
>> Thank you very much!
>> Bye

Mime
View raw message