lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Bosco Durai <bo...@apache.org>
Subject shard range is empty...
Date Fri, 20 Nov 2015 17:39:48 GMT
I created a 3 shard cluster, but seems for one of the shard, the range is empty. Anyway to
fix it without deleting and recreating the collection?

2015-11-20 08:59:50,901 [solr,writer=0] ERROR apache.solr.client.solrj.impl.CloudSolrClient
(CloudSolrClient.java:902) - Request to collection my_collection failed due to (400) org.apache.solr.common.SolrException:
No active slice servicing hash code b637e7f1 in DocCollection(my_collection)={
  "replicationFactor":"1",
  "shards":{
    "shard2":{
      "range":"d5550000-2aa9ffff",
      "state":"active",
      "replicas":{"core_node2":{
          "core":"my_collection_shard2_replica1",
          "base_url":"http://172.22.64.65:8886/solr",
          "node_name":"172.22.64.65:8886_solr",
          "state":"active",
          "leader":"true"}}},
    "shard3":{
      "range":"2aaa0000-7fffffff",
      "state":"active",
      "replicas":{"core_node3":{
          "core":"my_collection_shard3_replica1",
          "base_url":"http://172.22.64.64:8886/solr",
          "node_name":"172.22.64.64:8886_solr",
          "state":"active",
          "leader":"true"}}},
    "shard1":{
      "parent":null,
      "range":null,
      "state":"active",
      "replicas":{"core_node4":{
          "core":"my_collection_shard1_replica1",
          "base_url":"http://172.22.64.63:8886/solr",
          "node_name":"172.22.64.63:8886_solr",
          "state":"active",
          "leader":"true"}}}},
  "router":{"name":"compositeId"},
  "maxShardsPerNode":"1",
  "autoAddReplicas":"false"}, retry? 0

Thanks

Bosco



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message