lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Miller <dmil...@amfes.com>
Subject Re: Upgrading from 4.x to 5.x
Date Thu, 19 Nov 2015 08:58:18 GMT
Thank you - but I still don't understand where to install/copy/modify 
config files or schema to point at my current index. My 4.x schema.xml was 
fairly well optimized, and I believe I removed any deprecated usage, so I 
assume it would be compatible with the 5.x server.

Daniel



On November 18, 2015 4:55:40 AM Jan Høydahl <jan.asf@cominvent.com> wrote:

> Hi
>
> You could try this
>
> Instead of example/, use the server/ folder (it has Jetty in it)
> Start Solr using bin/solr start script instead of java -jar start.jar …
> Leave your solrconfig and schema as is to keep back-compat with 4.x.
> You may need to remove use of 3.x classes that were deprecated in 4.x
>
> https://cwiki.apache.org/confluence/display/solr/Major+Changes+from+Solr+4+to+Solr+5
>
> --
> Jan Høydahl, search solution architect
> Cominvent AS - www.cominvent.com
>
>> 18. nov. 2015 kl. 10.10 skrev Daniel Miller <dmiller@amfes.com>:
>>
>> Hi!
>>
>> I'm a very inexperienced user with Solr.  I've been using Solr to provide 
>> indexes for my Dovecot IMAP server.  Using version 3.x, and later 4.x, I 
>> have been able to do so without too much of a challenge.  However, version 
>> 5.x has certainly changed quite a bit and I'm very uncertain how to proceed.
>>
>> I currently have a working 4.10.3 installation, using the "example" server 
>> provided with the Solr distribution package, and a schema.xml optimized for 
>> Dovecot.  I haven't found anything on migrating from 4 to 5 - at least 
>> anything I actually understood.  Can you point me in the right direction?
>>
>> --
>> Daniel
>



Mime
View raw message