lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: collection API timeout
Date Thu, 05 Nov 2015 15:08:37 GMT
You should be able to go straight to 5.3.1

Solr/Lucene tries to guarantee that the indexes are readable
one major version back, i.e. 5.x Solr/Lucene code should
be able to read any 4.x index. New segments are written in the
most modern format, so over time all the 4x remnants should
disappear.

You can also use the IndexUpgrader tool to make upgrade
the index, see:
https://lucene.apache.org/core/5_3_1/core/org/apache/lucene/index/IndexUpgrader.html
take a backup first of course ;)

You can also optimize after upgrading to 5.3.1 which will rewrite
all the segments too, but personally I'd run the IndexUpgrade
by preference unless it's an index that doesn't change very often if
at all.

All that said, you should simply be able to install 5.3.1 and start
running, running
the IndexUpgrade tool or optimizing isn't actually necessary.

Best,
Erick

On Thu, Nov 5, 2015 at 1:28 AM, Julien David <j.david@decalog.net> wrote:
> Seems I'ill need to upgrade to 5.3.1
>
> It is possible to upgrade from 4.9 to 5.3 or do I need deploy all
> intermediate versions?
>
> Thks
>
>
>
>>
>
>
>

Mime
View raw message