lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ahmet Arslan <iori...@yahoo.com.INVALID>
Subject Re: Wildcard search not working
Date Thu, 11 Aug 2016 14:00:02 GMT
Hi Chiristian,

The query r?che may not return at least the same number of matches as roche depending on your
analysis chain.
The difference is roche is analyzed but r?che don't. Wildcard queries are executed on the
indexed/analyzed terms.
For example, if roche is indexed/analyzed as roch, the query r?che won't match it.

Please see : https://wiki.apache.org/solr/MultitermQueryAnalysis

Ahmet



On Thursday, August 11, 2016 4:42 PM, "Ribeaud, Christian (Ext)" <christian.ribeaud@novartis.com>
wrote:
Hi,

What would be the reasons making the wildcard search for Lucene Query Parser NOT working?

We are using Solr 5.4.1 and, using the admin console, I am triggering for instance searches
with term 'roche' in a specific core. Everything fine, I am getting for instance two matches.
I would expect at least the same number of matches with term 'r?che'. However, this does NOT
happen. I am getting zero matches. Same problem occurs with 'r*che'. 'roch?' does not work
neither but 'roch*' works.

Switching debug mode brings following output:

"debug": {
    "rawquerystring": "roch?",
    "querystring": "roch?",
    "parsedquery": "text:roch?",
    "parsedquery_toString": "text:roch?",
    "explain": {},
    "QParser": "LuceneQParser",
...

Any idea? Thanks and cheers,

christian

Mime
View raw message