lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexandre Drouin <alexandre.dro...@orckestra.com>
Subject RE: Solr 4.10.2 Enabling Basic Authentication in HTTP
Date Wed, 05 Oct 2016 18:10:07 GMT
I forgot to mention that I also tried this connector without success:

<Call name="addConnector">
      <Arg>
          <New class="org.eclipse.jetty.server.bio.SocketConnector">
            <Set name="host"><SystemProperty name="jetty.host" /></Set>
            <Set name="port"><SystemProperty name="jetty.port" default="8983"/></Set>
            <Set name="maxIdleTime">50000</Set>
            <Set name="lowResourceMaxIdleTime">1500</Set>
            <Set name="statsOn">false</Set>
          </New>
      </Arg>
  </Call>

If I remove the basic authentication related configuration from web.xml I can access Solr
without issue so I know the connector is working, I just can't get it to work with basic auth.


Alexandre Drouin


-----Original Message-----
From: Alexandre Drouin [mailto:alexandre.drouin@orckestra.com] 
Sent: October 5, 2016 2:07 PM
To: solr-user@lucene.apache.org
Subject: Solr 4.10.2 Enabling Basic Authentication in HTTP
Importance: High

Hi,

I currently have basic authentication enabled with HTTPS and it is working great.  I want
to remove SSL from my Solr installation (master/slave) while keeping the basic authentication.
 To this effect, I removed the SslSelectChannelConnector connector from my jetty.xml file
and I replaced it with the SelectChannelConnector connector like so:

    <Call name="addConnector">
      <Arg>
          <New class="org.eclipse.jetty.server.nio.SelectChannelConnector">
            <Set name="host"><SystemProperty name="jetty.host" /></Set>
            <Set name="port"><SystemProperty name="jetty.port" default="8983"/></Set>
            <Set name="maxIdleTime">50000</Set>
            <Set name="Acceptors">2</Set>
            <Set name="statsOn">false</Set>
            <Set name="lowResourcesConnections">5000</Set>
            <Set name="lowResourcesMaxIdleTime">5000</Set>
          </New>
      </Arg>
    </Call>

However I get a 403 error when I try to access the Solr server (url: /solr).  I did not modify
the security-constraint nodes of my web.xml file since the basic authentication was working
in HTTPS and I can provide the file if necessary.

How can I enable basic authentication for HTTP in Solr 4.10.2 ?

Alexandre Drouin
Mime
View raw message