lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kamal Kishore Aggarwal <kkroyal....@gmail.com>
Subject Clob transformer not working in DIH
Date Fri, 09 Dec 2016 07:35:05 GMT
Hi,

I am using solr 5.4.1. Here I am using dataimport handler to index data
with SQL Server.

I am using CLOB transformer to convert clob value to string. Indexing is
working fine but clob transformation is not working. Expected string value
is not coming for clob column. There is no error or exception coming in log.

Here is the configuration:

<dataConfig>
<datasource name="one"
driver="com.microsoft.sqlserver.jdbc.SQLServerDriver" url="jdbc:sqlserver
<sqlserver://10.0.0.102;databaseName=Dictionary;>://
<sqlserver://10.0.0.102;databaseName=Dictionary;>localhost
<sqlserver://10.0.0.102;databaseName=Dictionary;>;
<sqlserver://10.0.0.102;databaseName=Dictionary;>databaseName
<sqlserver://10.0.0.102;databaseName=Dictionary;>=Dictionary;
<sqlserver://10.0.0.102;databaseName=Dictionary;>"    user="sa"
password="xxxxxxxx"
batchSize="5" />

    <document>

        <entity name="TestEntity" query="SELECT id, rules FROM tag"
transformer="ClobTransformer">

            <field column="Id" name="id" />

            <field column="rules" name="rules"  clob="true"/>

        </entity>

    </document>

</dataConfig>

I tried using RegexTransformer, it worked. But ClobTransformer is not
working. Please assist.

Regards
Kamal

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message