lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jake Gillespie <jdgillespi...@gmail.com>
Subject How to load plugins with Solr 4.9 and SolrCloud
Date Tue, 03 Jan 2017 18:20:35 GMT
Hi everyone,

I'm trying to load a custom plugin with Solr 4.9. I'm able to do this
running Solr 4.9 on a single server but not when running as a cluster. I'm
hoping for some advice on how best to move forward, whether it be
configuring the current infrastructure correctly or upgrading Solr.

When running on a single server, I followed the instructions here
<https://wiki.apache.org/solr/SolrPlugins>. In short, I placed the jar in a
directory on the server, added this directory using the sharedLib attribute
to solr.xml and then used the lib directive in solrconfig.xml to point to
this jar.

In cluster mode, I've tried the following:

   - Adding the plugin with the blob store API as per the instructions here
   <https://cwiki.apache.org/confluence/display/solr/Adding+Custom+Plugins+in+SolrCloud+Mode>.
   However, the blob store API is added in Solr 5.0.
   - Adding the plugin as in the single server case. However, the <solr>
   tag in solr.xml appears to ignore the sharedLib attribute when running in
   SolrCloud.

Does anyone know if it's possible to run custom plugins in SolrCloud with
Solr 4.9? If so, are you able to see where I'm going wrong? I can provide
more detail on either of my attempted solutions if pertinent. If it's not
possible, I'll look into upgrading Solr.

Any advice would be appreciated.

Thanks,

Jake

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message