lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <apa...@elyograg.org>
Subject Re: A problem with depolying:solr6.5 report 404 error
Date Mon, 24 Apr 2017 13:33:33 GMT
On 4/24/2017 5:56 AM, Rick Leir wrote:
> David,
> Did you say Tomcat? Try to install without Tomcat. Then, after starting Solr, look in
solr.log.
> HTH -- Rick
>
> On April 23, 2017 9:44:30 PM EDT, David <gloriza@163.com> wrote:
>> I have a problem with deploying the solr6.5. my environment are
>> windows7+jdk 8u131+tomcat9.0+solr6.5. java run successfully, tomcat run
>> successfully, solr6.5 has been depolyed. Enter
>> http://localhost:8080/solr/index.html in firefox, and then report 404

+1 to what Rick said.

Although Solr is a webapp, since version 5.0, the only supported
deployment option is the jetty that Solr comes with and the scripts
provided.

https://wiki.apache.org/solr/WhyNoWar

It is possible that in the last two years (since 5.0 was released) Solr
has become reliant on the code mechanisms provided by Jetty and certain
things will no longer function under Tomcat.

You could try the url without "index.html" and see whether it works ...
but you're running an unsupported configuration. To get help, you're
going to have to run it as it was shipped, not in Tomcat.

I tried the URL you mentioned on a Solr 6.5 download running with the
included scripts, and it worked ... but under Tomcat, we can't be sure
of anything.

Thanks,
Shawn


Mime
View raw message