lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Rowe <sar...@gmail.com>
Subject Re: BUILD FAILED solr 6.5.0
Date Wed, 19 Apr 2017 15:01:11 GMT
Hi Bernd,

Your Ivy may be outdated - the project requires minimum 2.3.

Try removing all pre-2.3 ivy-*.jar files from ~/.ant/lib/, then running “ant ivy-bootstrap”.

--
Steve
www.lucidworks.com

> On Apr 19, 2017, at 10:55 AM, Bernd Fehling <bernd.fehling@uni-bielefeld.de> wrote:
> 
> Tried today to have a look at solr 6.5.0.
> - download solr-6.5.0-src.tgz from apache.org and extracted to workspace
> - ant eclipse
> - imported to eclipse neon as new project
> - from eclipse in lucene subdir clicked on build.xml and selected
>  "Run As" --> "Ant Build..."
> - selected "package" and "Run"
> 
> Result:
> ...
>  [javadoc] Loading source files for package org.apache.lucene.search.spans...
>  [javadoc] Loading source files for package org.apache.lucene.store...
>  [javadoc] Loading source files for package org.apache.lucene.util...
>  [javadoc] Loading source files for package org.apache.lucene.util.automaton...
>  [javadoc] Loading source files for package org.apache.lucene.util.fst...
>  [javadoc] Constructing Javadoc information...
>  [javadoc] Standard Doclet version 1.8.0_121
>  [javadoc] Building tree for all the packages and classes...
>  [javadoc] Building index for all the packages and classes...
>  [javadoc] Building index for all classes...
>     [exec] Result: 128
>      [jar] Building jar:
> /srv/www/solr/workspace_neon_solr_6_5_0/solr-6.5.0/lucene/build/test-framework/lucene-test-framework-6.5.0-SNAPSHOT-javadoc.jar
> javadocs:
> changes-to-html:
>    [mkdir] Created dir: /srv/www/solr/workspace_neon_solr_6_5_0/solr-6.5.0/lucene/build/docs/changes
>   [delete] Deleting: /srv/www/solr/workspace_neon_solr_6_5_0/solr-6.5.0/lucene/build/doap.lucene.version.dates.csv
>     [copy] Copying 3 files to /srv/www/solr/workspace_neon_solr_6_5_0/solr-6.5.0/lucene/build/docs/changes
> ivy-availability-check:
> ivy-fail:
> ivy-configure:
> [ivy:configure] :: loading settings :: file = /srv/www/solr/workspace_neon_solr_6_5_0/solr-6.5.0/lucene/top-level-ivy-settings.xml
> resolve-groovy:
> [ivy:cachepath] :: resolving dependencies :: org.codehaus.groovy#groovy-all-caller;working
> [ivy:cachepath] 	confs: [default]
> [ivy:cachepath] 	found org.codehaus.groovy#groovy-all;2.4.8 in public
> [ivy:cachepath] :: resolution report :: resolve 10ms :: artifacts dl 0ms
> 	---------------------------------------------------------------------
> 	|                  |            modules            ||   artifacts   |
> 	|       conf       | number| search|dwnlded|evicted|| number|dwnlded|
> 	---------------------------------------------------------------------
> 	|      default     |   1   |   0   |   0   |   0   ||   1   |   0   |
> 	---------------------------------------------------------------------
> resolve-markdown:
> 
> BUILD FAILED
> /srv/www/solr/workspace_neon_solr_6_5_0/solr-6.5.0/lucene/common-build.xml:2415: ivy:cachepath
doesn't support the nested "dependency" element.
> 
> 
> Any idea what is going wrong?
> 
> Something with ivy:dependency within ivy:cachepath, but how to fix it?
> 
> Regards
> Bernd


Mime
View raw message