lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <apa...@elyograg.org>
Subject Re: recommended zookeeper version for solr cloud
Date Mon, 01 May 2017 14:16:26 GMT
On 4/26/2017 3:44 AM, David Michael Gang wrote:
> Which version of external zookeper is recommended to use in production
> environments? 3.4.6 which is the version shipped with solr or 3.4.10
> which is the latest stable?

If it were me, I would use the latest.  The list of bugs fixed in each
ZK version after 3.4.6 is quite long.

In 3.4.10, the use of certain 4lw (four letter words) is disabled by
default by ZOOKEEPER-2693.  I do not know whether Solr uses any of the
disabled 4lw commands, but because Solr includes native ZK client
access, I would assume that it does not.  If you find that Solr doesn't
work correctly, you can try the"4lw.commands.whitelist=*" config option
to re-enable them and restart zookeeper.

http://zookeeper.apache.org/doc/r3.4.10/zookeeperAdmin.html
 
Thanks,
Shawn


Mime
View raw message