lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bernd Fehling <bernd.fehl...@uni-bielefeld.de>
Subject Re: SolrCloud - Connection to Solr lost
Date Thu, 04 May 2017 12:14:35 GMT
After many, many tests it is "time to say goodbye" to SolrCloud and
I belief it is not running and useful at all. :-(


I reduced to only 3 servers (Solr and Zookeeper) and tried to
_only_ create a simple single collection, but even this fails.

bin/solr create -c base -d /home/solr/solr/solr/server/solr/configsets/base_configs/

<console>
Connecting to ZooKeeper at solrmn01:2181,solrmn02:2181,solrmn03:2181 ...
INFO  - 2017-05-04 13:56:12.889; org.apache.solr.client.solrj.impl.ZkClientClusterStateProvider;
Cluster at
solrmn01:2181,solrmn02:2181,solrmn03:2181 ready
Uploading /home/solr/solr/solr/server/solr/configsets/base_configs/conf for config base to
ZooKeeper at solrmn01:2181,solrmn02:2181,solrmn03:2181

Creating new collection 'base' using command:
http://solrmn01.ub.de:8983/solr/admin/collections?action=CREATE&name=base&numShards=1&
replicationFactor=1&maxShardsPerNode=1&collection.configName=base

INFO  - 2017-05-04 13:57:01.341; org.apache.http.impl.client.DefaultRequestDirector; I/O exception
(org.apache.http.NoHttpResponseException)
caught when processing request to {}->http://solrmn01.ub.de:8983: The target server failed
to respond
INFO  - 2017-05-04 13:57:01.343; org.apache.http.impl.client.DefaultRequestDirector; Retrying
request to {}->http://solrmn01.ub.de:8983

ERROR: Connection refused (Connection refused)
</console>

Regards
Bernd


Am 04.05.2017 um 10:13 schrieb Bernd Fehling:
> Hi list,
> next problem with SolrCloud.
> Situation:
> - 5 x Zookeeper fresh, clean on 5 server
> - 5 x Solr 6.5.1 fresh, clean on 5 server
> - start of Zookeepers
> - upload of configset with Solr to Zookeepers
> - start of only one Solr instance port 8983 on each server
> - With Solr Admin GUI check that all Solr instances are up and in Zookeeper
> - click on Collection -> Add Collection
> - fill in "name", "config set" (the uploaded config), numShards 5,
>   replicationFactor 1
> - click on "Add Collection"
> 
> Response ist red banner with "Connection to Solr lost" and
> "Please check the Solr instance".
> 
> "bin/solr status" says that _all_ Solr instances on _all_ servers are gone.
> 
> What am I doing wrong?
> 
> I just want to setup 5 Zookeeper on 5 server, have 5 Shards on 5 server
> and want to create a new Collection with Admin Gui.
> Is this at all possible?
> 
> Regards
> Bernd
> 

Mime
View raw message