lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: solr-6.3.0 error port is running already
Date Tue, 02 May 2017 20:01:46 GMT
Well, if an ephemeral node exists, restarting your Zookeeper ensemble
will delete it. Not sure what the precursor here is.

Are you absolutely and totally sure you don't have a solr process
still running on the node you try and start the shows this error? 'ps
aux | grep solr' will show you all of the running Solr instances on a
machine.

Best,
Erick

On Tue, May 2, 2017 at 12:45 PM, Satya Marivada
<satya.chaitanya@gmail.com> wrote:
> Any ideas?  "null:org.apache.solr.common.SolrException: A previous
> ephemeral live node still exists. Solr cannot continue. Please ensure that
> no other Solr process using the same port is running already."
>
> Not sure, if JMX enablement has caused this.
>
> Thanks,
> Satya
>
> On Tue, May 2, 2017 at 3:10 PM Satya Marivada <satya.chaitanya@gmail.com>
> wrote:
>
>> Hi,
>>
>> I am getting the below exception all of a sudden with solr-6.3.0.
>> "null:org.apache.solr.common.SolrException: A previous ephemeral live node
>> still exists. Solr cannot continue. Please ensure that no other Solr
>> process using the same port is running already."
>>
>> We are using external zookeeper and have restarted solr many times. There
>> is no solr running on those ports already. Any suggestions. Looks like a
>> bug. Had started using jmx option and then started getting it. Turned jmx
>> off, still getting the same issue.
>>
>> We are in crunch of time, any workaround to get it started would be
>> helpful. Not sure where solr is seeing that port, when everything is
>> started clean.
>>
>> Thanks,
>> Satya
>>

Mime
View raw message