lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Atita Arora <atitaar...@gmail.com>
Subject High CPU utilization on Upgrading to Solr Version 6.3
Date Wed, 26 Jul 2017 07:49:41 GMT
Hi ,

We upgrade our production Solr to version 6.3 from Version 4.3.2 about a
week ago.
We had our Dev / QA / staging on the same version (6.3) before finally
releasing the application leveraging Solr 6.3.

We did our functional and load testing on these boxes , however when we
released it to production along with the same application (using SolrJ to
query Solr) , we ran into severe CPU issues.
Just to add we're on Master - Slave where master has index on
NRTCachingDirectory
and Slave on RAMDirectory.

As soon as we placed the slaves under load balancer , under NO LOAD
condition as well , the slave went from a load of 4 -> 10 -> 16 - > 100 in
12 mins.

I suspected this to be caused due to replication but this is never ending ,
so before this crashed we de-provisioned it and brought it down.

I'm not sure what could possibly cause it.

I looked into the caches , where documentcache , filtercache ,
queryresultcaches are set to defaults 1024 and 100 documents.

I tried observing the GC activity on GCViewer too , which does'nt really
shows something alarming (as in what I feel) - a sampler at
https://pastebin.com/cnuATYrS

Can anyone possibly tell me the reasons ?

Thanks a lot in advance.

Atita

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message