lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emir Arnautović <emir.arnauto...@sematext.com>
Subject Re: "editorialMarkerFieldName"
Date Tue, 13 Feb 2018 09:28:47 GMT
Hi Chris,
Guessing here but this feature might be introduced in case you have use (have to use) ‘elevated’
field in your schema for some other purpose. Maybe if field name was “_elevated_", then
it would be redundant.

Emir

--
Monitoring - Log Management - Alerting - Anomaly Detection
Solr & Elasticsearch Consulting Support Training - http://sematext.com/



> On 12 Feb 2018, at 22:44, Chris Hostetter <hossman_lucene@fucit.org> wrote:
> 
> 
> IIUC the "editorialMarkerFieldName" config option is a bit missleading.
> 
> Configuring that doesn't automatically add a field w/that name to your 
> docs to indicate which of them have been elevated -- all it does is 
> provide an *override* for what name can be used to refer to the 
> "[elevated]" DocTransformer.
> 
> So by default you can do something like this...
> 
> 	q=ipod&df=text&fl=id,[elevated]
> 
> ...but if you have <str name="editorialMarkerFieldName">foo</str> in 
> your searchComponent config, then instead of "[elevated]" you would have 
> to say...
> 
>        q=ipod&df=text&fl=id,[foo]
> 
> ...to get the same info.
> 
> It's a very weird and silly feature -- i honestly can't give you 
> any good explaination as towhy it was implemented that way.
> 
> 
> 
> : Date: Mon, 5 Feb 2018 04:12:27 +0000
> : From: Sadiki Latty <slatty@uottawa.ca>
> : Reply-To: solr-user@lucene.apache.org
> : To: "solr-user@lucene.apache.org" <solr-user@lucene.apache.org>
> : Subject: "editorialMarkerFieldName"
> : 
> : Hello
> : 
> : I have added the "editorialMarkerFieldName" to my search component but nothing happens.
Am I missing something in my configuration? I have confirmed that the elevation aspect is
working as it should. The documents in the 'elevate.xml' are being elevated so the component
is being read, but specifically that parameter does not seem to change the result. I have
a configuration similar to the one below (copied from the guide) and I have the elevator str
in my 'last-components' section of my request handler.
> : 
> : <searchComponent name="elevator" class="solr.QueryElevationComponent" >
> :   <!-- pick a fieldType to analyze queries -->
> :   <str name="queryFieldType">string</str>
> :   <str name="config-file">elevate.xml</str>
> :  <str name="editorialMarkerFieldName">foo</str>
> : </searchComponent>
> : 
> : 
> : Am I misunderstanding the purpose of this parameter? Isnt it supposed to distinguish
the elevated results from the normal results with the given string?
> : 
> : I am using Solr 7.1.0 btw
> : 
> : Thanks in advance,
> : 
> : Sid
> : 
> 
> -Hoss
> http://www.lucidworks.com/


Mime
View raw message