lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "thunderz.solr" <thunderz.s...@gmail.com>
Subject Re: solr src 6.0 ant error
Date Thu, 01 Mar 2018 14:06:02 GMT
苗海泉 wrote
> I encountered a problem, when I was in the process of compiling solr6.0
> source error, I have installed the ant and ivy, and then solr6 source code
> catalog Executive eclipse ant eclipse would like to generate a project
> error as follows "
> Buildfile: D: \ solr-6.0.0-src \ solr-6.0.0 \ build.xml
> 
> BUILD FAILED
> D: \ solr-6.0.0-src \ solr-6.0.0 \ build.xml: 21: The following error
> occurred while executing this lin
> D: \ solr-6.0.0-src \ solr-6.0.0 \ lucene \ common-build.xml: 570:
> java.lang.NullPointerException
>         at java.util.Arrays.stream (Arrays.java:5004)
>         at java.util.stream.Stream.of (Stream.java:1000)
>         at java.util.stream.ReferencePipeline $ 7 $ 1.accept
> (ReferencePipeline.java:267)
>         at java.util.stream.ReferencePipeline $ 3 $ 1.accept
> (ReferencePipeline.java:193)
>         at java.util.Spliterators $ ArraySpliterator.forEachRemaining
> (Spliterators.java:948)
> 
> lucene.tgz.unpacked This directory does not exist in the system, what do I
> do wrong?

I had the same problem when I used ant 1.10.2. (MacOS, java version
"1.8.0_131", ant version "1.10.2")
When I downgrade ant to 1.9.10, everything goes fine.
I wonder if this is a bug of ant.




--
Sent from: http://lucene.472066.n3.nabble.com/Solr-User-f472068.html

Mime
View raw message