lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Susheel Kumar <susheel2...@gmail.com>
Subject Re: ZK CLI script giving IOException doing upconfig
Date Wed, 04 Apr 2018 19:23:37 GMT
Hi Doug,  are you able to connect to Zookeeper thru Zookeeper zkCli.sh or
does Zookeeper.out show anything useful.

Thnx

On Wed, Apr 4, 2018 at 2:13 PM, Doug Turnbull <
dturnbull@opensourceconnections.com> wrote:

> Thanks for the responses. Yeah I thought they were weird errors too... :)
>
> Below are the logs from zookeeper running in foreground after a connection
> attempt. But this Exception looks suspicous to me:
>
> [NIOServerCxn.Factory:0.0.0.0/0.0.0.0:2181:NIOServerCnxn@383] - Exception
> causing close of session 0x10024db7e280006: *Len error 5327937*
>
> Has anyone seen this before? The LenError seems to be a thread to google...
>
> 2018-04-04 14:06:01,210 [myid:] - INFO  [NIOServerCxn.Factory:
> 0.0.0.0/0.0.0.0:2181:NIOServerCnxnFactory@215] - Accepted socket
> connection
> from /127.0.0.1:55078
> 2018-04-04 14:06:01,218 [myid:] - INFO  [NIOServerCxn.Factory:
> 0.0.0.0/0.0.0.0:2181:ZooKeeperServer@938] - Client attempting to establish
> new session at /127.0.0.1:55078
> 2018-04-04 14:06:01,219 [myid:] - INFO  [SyncThread:0:ZooKeeperServer@683]
> - Established session 0x10024db7e280006 with negotiated timeout 30000 for
> client /127.0.0.1:55078
> 2018-04-04 14:06:01,361 [myid:] - WARN  [NIOServerCxn.Factory:
> 0.0.0.0/0.0.0.0:2181:NIOServerCnxn@383] - Exception causing close of
> session 0x10024db7e280006: Len error 5327937
> 2018-04-04 14:06:01,362 [myid:] - INFO  [NIOServerCxn.Factory:
> 0.0.0.0/0.0.0.0:2181:NIOServerCnxn@1040] - Closed socket connection for
> client /127.0.0.1:55078 which had sessionid 0x10024db7e280006
> 2018-04-04 14:06:01,956 [myid:] - INFO  [NIOServerCxn.Factory:
> 0.0.0.0/0.0.0.0:2181:NIOServerCnxnFactory@215] - Accepted socket
> connection
> from /0:0:0:0:0:0:0:1:55079
> 2018-04-04 14:06:01,959 [myid:] - INFO  [NIOServerCxn.Factory:
> 0.0.0.0/0.0.0.0:2181:ZooKeeperServer@931] - Client attempting to renew
> session 0x10024db7e280006 at /0:0:0:0:0:0:0:1:55079
> 2018-04-04 14:06:01,960 [myid:] - INFO  [NIOServerCxn.Factory:
> 0.0.0.0/0.0.0.0:2181:ZooKeeperServer@683] - Established session
> 0x10024db7e280006 with negotiated timeout 30000 for client
> /0:0:0:0:0:0:0:1:55079
> 2018-04-04 14:06:03,223 [myid:] - WARN  [NIOServerCxn.Factory:
> 0.0.0.0/0.0.0.0:2181:NIOServerCnxn@376] - Unable to read additional data
> from client sessionid 0x10024db7e280006, likely client has closed socket
> 2018-04-04 14:06:03,223 [myid:] - INFO  [NIOServerCxn.Factory:
> 0.0.0.0/0.0.0.0:2181:NIOServerCnxn@1040] - Closed socket connection for
> client /0:0:0:0:0:0:0:1:55079 which had sessionid 0x10024db7e2800
>
> On Wed, Apr 4, 2018 at 11:15 AM Shawn Heisey <apache@elyograg.org> wrote:
>
> > On 4/4/2018 7:14 AM, Doug Turnbull wrote:
> > > I've been struggling to do a basic upconfig both with embedded and
> actual
> > > Zookeeper in Solr 7.2.1 using the zkcli script on OSX.
> > >
> > > One variable, I recently upgraded to Java 9. I get slightly different
> > > errors on Java 8 vs 9
> >
> > <snip>
> >
> > > Java 9:
> > >
> > > doug@wiz$~/ws/foo(mas) $
> > > /Users/doug/bin/solr-7.2.1/server/scripts/cloud-scripts/zkcli.sh
> -zkhost
> > > localhost:2181 -cmd upconfig -confdir solr_home/foo/ -confname foo_conf
> > > WARN  - 2018-04-04 09:05:28.194;
> > > org.apache.zookeeper.ClientCnxn$SendThread; Session 0x100244e8ffb0004
> for
> > > server localhost/127.0.0.1:2181, unexpected error, closing socket
> > > connection and attempting reconnect
> > > java.io.IOException: Connection reset by peer
> >
> > <snip>
> >
> > > Java 8 gives the error
> > >
> > > java.io.IOException: Protocol wrong type for socket
> > >
> > > WARN  - 2018-04-04 09:10:11.879;
> > > org.apache.zookeeper.ClientCnxn$SendThread; Session 0x10024db7e280002
> for
> > > server localhost/0:0:0:0:0:0:0:1:2181, unexpected error, closing
> socket
> > > connection and attempting reconnect
> > > java.io.IOException: Protocol wrong type for socket
> >
> > I'm with Erick on this.  These are REALLY weird errors. The stacktraces
> > for the errors are entirely in ZooKeeper and Java code, not Solr code.
> > The log for Java 9 does have an entry that mentions Solr classes, but
> > that's a disconnect after the error, not part of the error.
> >
> > Are you getting any corresponding log messages in the ZK server log?
> >
> > The ZkCLI class is part of Solr, and does interface to ZK through Solr
> > internals, but ultimately it's ZK doing the work.
> >
> > The ZK client that's in Solr 7.2.1 is version 3.4.10.
> >
> > Thanks,
> > Shawn
> >
> > --
> CTO, OpenSource Connections
> Author, Relevant Search
> http://o19s.com/doug
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message