lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mugdha Varadkar <mugdha.varadkar...@gmail.com>
Subject Re: Trying to Restore older indexes in Solr7.2.1
Date Tue, 03 Apr 2018 09:22:49 GMT
Hi Shawn Heisey,

Thank you for the reply given here
<https://mail-archives.apache.org/mod_mbox/lucene-solr-user/201803.mbox/%3C4e2ef3ec-65b3-30e0-1274-6edf43bc09ce%40elyograg.org%3E>
.

Please find below answers to your questions,

is the collection using the compositeId router?

Yes collection used of both the versions are using compositeId router, PFA
screenshot of the same.
>
> You would need to look at the information in zookeeper for both versions

Any specific information I can check / look into: shall I check for
uploaded configs for the collection or any specific set of properties in
solrconfig.xml?
>From my earlier mail, trying to re-phrase my point #6 - The new documents
available after new collection creation got lost after restoring older
indexes (in step #5).
The difference between schema of solr-5.5.5 and schema that is there for
solr-7.2.1 is that, we are adding docValues on required fields to improvise
indexing of required fields.
Hence before upgrading from solr-5.5.5, I took a backup of documents using
restore-api and then upgraded solr from 5.5.5 to 7.2.1 and tried to restore
the backed-up data by converting the documents to the newer format using
the index-upgrader tool.
And, issue I got after restoring the documents of older version was : all
the documents that were there in collection that was created for solr-7.2.1
were not available at all.

Thanks,
Mugdha Varadkar

On Wed, Mar 28, 2018 at 12:46 PM, Mugdha Varadkar <
mugdha.varadkar010@gmail.com> wrote:

> Hi,
>
> I am trying to restore Solr 5.5.5 indexes into Solr 7.2.1
>
> Performed below steps:
>
>    1. Upgraded the indexes to Solr 6.6.2 indexes using IndexUpgraded Tool
>    <https://lucene.apache.org/solr/guide/7_0/indexupgrader-tool.html#indexupgrader-tool>
>    Command used : java -cp server/solr-webapp/webapp/WEB-
>    INF/lib/lucene-core-6.6.2.jar:server/solr-webapp/webapp/WEB-
>    INF/lib/lucene-backward-codecs-6.6.2.jar org.apache.lucene.index.IndexUpgrader
>    -verbose /usr/local/solr_5_5_data/index/
>    2. Deleted the old collection used previously, as there is a change in
>    schema file.
>    3. Created new collection for new schema. Keeping the replication and
>    shards same as old collection.
>    4. Now there is data going into new collection.
>    5. Then I restore the upgraded indexes using replication API.(As the
>    backup was taken using that.)
>    6. The indexes got restored but the new data created after new
>    collection creation was not available.
>
> Can someone suggest what I missed during upgrading the indexes ?
>
> Thanks,
> Mugdha Varadkar
>

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message