lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Atita Arora <atitaar...@gmail.com>
Subject SPLITSHARD throwing OutOfMemory Error
Date Tue, 25 Sep 2018 14:39:30 GMT
Hi,

I am working on a test setup with Solr 6.1.0 cloud with 1 collection
sharded across 2 shards with no replication. When triggered a SPLITSHARD
command it throws "java.lang.OutOfMemoryError: Java heap space" everytime.
I tried this with multiple heap settings of 8, 12 & 20G but every time it
does create 2 sub-shards but then fails eventually.
I know the issue => https://jira.apache.org/jira/browse/SOLR-5214 has been
resolved but the trace looked very similar to this one.
Also just to ensure that I do not run into exceptions due to merge as
reported in this ticket, I also tried running optimize before proceeding
with splitting the shard.
I issued the following commands :

1.
http://localhost:8983/solr/admin/collections?collection=testcollection&shard=shard1&action=SPLITSHARD

This threw java.lang.OutOfMemoryError: Java heap space

2.
http://localhost:8983/solr/admin/collections?collection=testcollection&shard=shard1&action=SPLITSHARD&async=1000

Then I ran with async=1000 and checked the status. Every time It's creating
the sub shards, but not splitting the index.

Is there something that I am not doing correctly?

Please guide.

Thanks,
Atita

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message