lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Schaum Mallik <schaum.mal...@gmail.com>
Subject Re: SolrCoreInitializationException after restart of one solr node
Date Thu, 20 Sep 2018 15:25:30 GMT
ok so that’s the problem. The core.properties in the replicas under
/opt/solr/server/solr. So if I remove the file from all the replica folders
and also move the directories under /opt/solr/server/solr/configsets to
some backup location and restart this node then hopefully it should start
working correct?

Thank you

On Thursday, September 20, 2018, Shawn Heisey <apache@elyograg.org> wrote:

> On 9/20/2018 9:13 AM, Schaum Mallik wrote:
>
>> In response to this mistake that I did of keeping the core.properties in
>> the configuration directory when it was uploaded to zookeeper, how should
>> I
>> go about fixing it?
>>
>
> A core.properties file in the config in ZK will not cause any problems.
> It shouldn't be there, but it would be ignored.
>
> This problem is happening because you have a core.properties file in
> directories under /opt/solr/server/solr, so Solr is seeing that and loading
> the location as a core. Because you're in cloud mode, it tries to get
> information about the node from ZK, and it's not there, because when those
> core.properties files were created, the instance was NOT running in cloud
> mode.
>
> Thanks,
> Shawn
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message