lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anchal Sharma2" <anchs...@in.ibm.com>
Subject Solr not starting after enabling SSL
Date Wed, 03 Apr 2019 06:54:17 GMT
 
Hi All,

We recently migrated our existing solr(version 5.3.0) from AIX OS server to Linux based server.And
it works fine(http solr) .
RHEL version 7.6
Java version 1.8(IBM Java)

But now ,when trying to enable SSL over same ,the solr doesnt start after enabling SSL.
It says "Address already in use" despite there being no solr up .

2019-04-03 06:29:29.892 WARN  (main) [   ] o.e.j.u.c.AbstractLifeCycle FAILED ServerConnector@cdf341f{SSL-http/1.1}{0.0.0.0:8983}:
java.net.BindException: Address already in use
java.net.BindException: Address already in use
        at sun.nio.ch.Net.bind0(Native Method)
        at sun.nio.ch.Net.bind(Net.java:460)
        at sun.nio.ch.Net.bind(Net.java:452)
        at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:253)
        at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:86)
        at org.eclipse.jetty.server.ServerConnector.open(ServerConnector.java:321)
        at org.eclipse.jetty.server.AbstractNetworkConnector.doStart(AbstractNetworkConnector.java:80)
        at org.eclipse.jetty.server.ServerConnector.doStart(ServerConnector.java:236)
        at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
        at org.eclipse.jetty.server.Server.doStart(Server.java:366)
        at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
        at org.eclipse.jetty.xml.XmlConfiguration$1.run(XmlConfiguration.java:1255)
        at java.security.AccessController.doPrivileged(AccessController.java:647)
        at org.eclipse.jetty.xml.XmlConfiguration.main(XmlConfiguration.java:1174)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:90)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
        at java.lang.reflect.Method.invoke(Method.java:508)
        at org.eclipse.jetty.start.Main.invokeMain(Main.java:321)
        at org.eclipse.jetty.start.Main.start(Main.java:817)
        at org.eclipse.jetty.start.Main.main(Main.java:112)


Steps used to enable solr SSL :https://lucene.apache.org/solr/guide/6_6/enabling-ssl.html
(Same was used over AIX server's solr to enable SSL and we were successful there)

Any suggestion would be highly appreciated!!

Thanks & Regards,
-------------------------------------------------
Anchal Sharma



Mime
View raw message