lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dwane Hall <dwaneh...@hotmail.com>
Subject Basic auth and index replication
Date Wed, 03 Apr 2019 08:15:17 GMT
Hey Solr community.



I’ve been following a couple of open JIRA tickets relating to use of the basic auth plugin
in a Solr cluster (https://issues.apache.org/jira/browse/SOLR-12584 , https://issues.apache.org/jira/browse/SOLR-12860)
and recently I’ve noticed similar behaviour when adding tlog replicas to an existing Solr
collection.  The problem appears to occur when Solr attempts to replicate the leaders index
to a follower on another Solr node and it fails authentication in the process.



My environment

Solr cloud 7.6

Basic auth plugin enabled

SSL



Has anyone else noticed similar behaviour when using tlog replicas?



Thanks,



Dwane



2019-04-03T13:27:22,774 5000851636 WARN  : [   ] org.apache.solr.handler.IndexFetcher : Master
at: https://myserver:myport/solr/mycollection_shard1_replica_n17/ is not available. Index
fetch failed by exception: org.apache.solr.client.solrj.impl.HttpSolrClient$RemoteSolrException:
Error from server at https://myserver:myport/solr/mycollection_shard1_replica_n17: Expected
mime type application/octet-stream but got text/html. <html>

<head>

<meta http-equiv="Content-Type" content="text/html;charset=utf-8"/>

<title>Error 401 require authentication</title>

</head>

<body><h2>HTTP ERROR 401</h2>

<p>Problem accessing /solr/mycollection_shard1_replica_n17/replication. Reason:

<pre>    require authentication</pre></p>

</body>

</html>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message